在线检测未来函数 | 股海网搜索 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股票内参 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 公式教程答疑 > 正文 公式解密改编QQ:78858997 官方QQ群:75780250 | 最新资源 | 热门资源
将公式改为选股公式的简易方法
  • 相关简介: 【将公式改为选股公式的简易方法 】 飞狐.分析家.大智慧1.大智慧L2.通达信 {同花顺因个人电脑关系,无法顺利启动,麻烦有研究的高手补充,谢谢!} 步骤一.将所有的显示式:,改为不显示式:= 选股条件的基本要求,为只能输出1个条件式,故需先将公式中所有的显示式:改为不显示式:=, 如果原来显示式后面接有线型描述(颜色.对齐..等),亦请一并删除(有些软件不支援 如:分析家) 例如: ma1:ma(c,5),colorred; ma2:ma(c,10),colorgreen,POINTDOT;
  • 内容标签: 股票软件,股票公式
  • 文件大小: 2KB
  • 浏览次数:
  • 运行环境: Win9x,Vista,WinXP
  • 编辑发布: 择股网
  • 软件来源: www.zegu.cn
  • 加入时间: 2009/12/27 8:26:21
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

【将公式改为选股公式的简易方法 】

飞狐.分析家.大智慧1.大智慧L2.通达信

{同花顺因个人电脑关系,无法顺利启动,麻烦有研究的高手补充,谢谢!}



步骤一.将所有的显示式":",改为不显示式":="

选股条件的基本要求,为只能输出1个条件式,故需先将公式中所有的显示式":"改为不显示式":=",

如果原来显示式后面接有线型描述(颜色.对齐..等),亦请一并删除(有些软件不支援 如:分析家)

例如:

ma1:ma(c,5),colorred;

ma2:ma(c,10),colorgreen,POINTDOT;

.....

先改为

ma1:=ma(c,5);

ma2:=ma(c,10);

.....



步骤二.找出选股条件,并写成选股式引用:

条件的寻找方法,依不同目的,大致可分以下几种:

1.''字''选股     如:''买''选股

方法:先找出公式中出现有''字''的地方,该式开头会以DRAW..TEXT开头,

DRAWTEXT   DRAWTEXTEX   DRAWYITEXT DRAWFLAGTEXT DRAWMOVETEXT

找到后,该函数(条件, ,''字'')后面括号内的第1个即为条件,将该条件复制出来并加上分号即可

例如:

{求''5日均>10日均''选股}

ma1:=ma(c,5);

ma2:=ma(c,10);

DRAWTEXT(ma1>ma2,ma1,''5日均>10日均'');

[解]

ma1:=ma(c,5);

ma2:=ma(c,10);

ma1>ma2;

2.图标选股     如:笑脸选股

方法:

先依不同软件,找出该图标的代号,

再找出公式中出现DRAWICON函数(条件, ,图标代号)的式子,对照图标的代号(括号内的第3个),如果该图标代号为所求代号,

该函数后面括号内的第1个即为条件,将该条件复制出来并加上分号即可

例如:

{求图标1选股}

ma1:=ma(c,5);

ma2:=ma(c,10);

DRAWicon(ma1>ma2,ma1,1);

[解]

ma1:=ma(c,5);

ma2:=ma(c,10);

ma1>ma2;

3.A线上穿(下穿)B线选股   {上穿--金叉,下穿--死叉}

方法:A线上穿B线:   cross(A,B);

    A线下穿B线:   cross(B,A);

例如:

{求ma1上穿ma2选股}

ma1:ma(c,5);

ma2:ma(c,10);

[解]

ma1:=ma(c,5);

ma2:=ma(c,10);

cross(ma1,ma2);

{求ma1下穿ma2选股}

ma1:ma(c,5);

ma2:ma(c,10);

[解]

ma1:=ma(c,5);

ma2:=ma(c,10);

cross(ma2,ma1);



4.线A上拐(下拐) 选股  

方法:线A上拐:   cross(A,ma(A,2)); 或   cross(A,ref(A,1));{aduo提供}

    线A下拐:   cross(ma(A,2),A); 或   cross(ref(A,1),A);{aduo提供}

例如:

{求改成ma1上拐}

ma1:ma(c,5);

[解]

ma1:=ma(c,5);

cross(ma1,ma(ma1,2));



ma1:=ma(c,5);

cross(ma1,ref(ma1,1));

{求改成ma1下拐}

ma1:ma(c,5);

[解]

ma1:=ma(c,5);

cross(ma(ma1,2),ma1);

或  

ma1:=ma(c,5);

cross(ref(ma1,1),ma1);

5.第1次出现条件A 选股

方法:先找出条件A,

    再利用cross(A,0.5);

例如:

{求改成第1次出现图标1选股}

ma1:=ma(c,5);

ma2:=ma(c,10);

DRAWicon(ma1>ma2,ma1,1);

[解1]

ma1:=ma(c,5);

ma2:=ma(c,10);

A:=ma1>ma2;

cross(A,0.5);

[解2--直接将条件A写入]

ma1:=ma(c,5);

ma2:=ma(c,10);

cross(ma1>ma2,0.5);

6.线变色选股 如:黄线变红色选股 (指标线为黄线,再利用函数变红色线)

方法:先依不同软件,找出条件A,

    再用cross(A,0.5);

(1)飞狐

条件在PARTLINE(条件A, ),colorred;括号内的第1个即为条件,将该条件复制出来并加上分号即可

例如:

{求黄线变红色选股   飞狐}

ma1:ma(c,5),coloryellow;

PARTLINE(ma1>REF(ma1,1),ma1),colorred;

[解]

ma1:=ma(c,5);

A:=ma1>REF(ma1,1);

cross(A,0.5);

(2)大智慧L2.分析家

条件在PARTLINE(   ,条件A,rgb(255,0,0),   , ...);

括号内为rgb(255,0,0)的前1个即为条件,将该条件复制出来并加上分号即可

例如:

{求黄线变红色选股   大智慧L2.分析家}

ma1:=ma(c,5);

PARTLINE(ma1,ma1>REF(ma1,1),rgb(255,0,0),1,rgb(255,255,0));

[解]

ma1:=ma(c,5);

A:=ma1>REF(ma1,1);

cross(A,0.5);

(3)通达信

条件在IF(条件A, ,DRAWNULL),colorred;括号内的第1个即为条件,将该条件复制出来并加上分号即可

例如:

{求黄线变红色选股   通达信}

MA1:MA(C,5),COLORYELLOW;

IF(MA1>REF(MA1,1),MA1,DRAWNULL),COLORRED;

[解]

MA1:=MA(C,5);

A:=MA1>REF(MA1,1);

CROSS(MA1>REF(MA1,1),0.5);

7.颜色柱选股

方法:先找出公式中出现有STICKLINE函数的地方,

找到后,核对该函数后面的颜色,是否为所求颜色,

若颜色相同,则括号内的第1个即为条件A,将该条件复制出来并加上分号即可

例如:

{求红色柱选股}

STICKLINE(c>o,h,l,0.8,1),colorred;

[解]

A:c>o;

{求第1次红色柱选股}

STICKLINE(c>o,h,l,0.8,1),colorred;

[解]

A:=c>o;

cross(A,0.5);步骤三.最后将所有绘图函数及单一输出值(如 0;   k;   if(,,); )全删除,使公式只剩1个选股式输出即成,

(若有2个以上条件,条件同时成立时,可在条件间用"and"连接;

   若有2个以上条件,条件不同时成立时,可在条件间用"or"连接)

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
将公式改为选股公式的简易方法下载