分享股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
分享到:
☆ 私募云 ☆ | 股软教程 | 公式教程 | 收藏股海网
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股票内参 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 大智慧公式 > 正文 ※ 在线检测公式未来函数 ※
  • 大智慧125个实用的选股公式 总有适合你的

  • 简介:大智慧125个实用的选股公式 总有适合你的 1.30个交易日内,股价跌幅达到一半的股票: xg:(hhv(c,30)-c)/hhv(c,30)0.5; 2,今天的量 是5天平均的 2倍以上 xg:vma(v,5)*2; 缩量 vol/ma(vol,10)0.3; 3,两天内,累计下跌等于或超过20%选股. xg:(ref(c,2)-c)/c0.2; 4,股价是25天以来新低. xg:cref(llv(c,25),1); 5,选股:EXPMA 5日与10日金叉 并且第二天的收盘价在EXPMA的5日
  • 标签:大智慧,选股公式 来源:www.guhai.com.cn 时间:12-03-31 点击: 下载:

股海网股票公式说明:股票公式文件使用以及说明(新手必读)!提供了公式源码的一般不提供文件下载,请了解!

大智慧125个实用的选股公式 总有适合你的

1.30个交易日内,股价跌幅达到一半的股票:
 xg:(hhv(c,30)-c)/hhv(c,30)>0.5;
 
2,今天的量   是5天平均的 2倍以上
 xg:v>ma(v,5)*2;
 
缩量
 vol/ma(vol,10)<0.3;
 
3,两天内,累计下跌等于或超过20%选股.
 xg:(ref(c,2)-c)/c>0.2;
 
4,股价是25天以来新低.
 xg:c<ref(llv(c,25),1);
 
5,选股:EXPMA 5日与10日金叉 并且第二天的收盘价在EXPMA的5日线以上.
 cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);
 
6,请编买入公式
 1. 将BIAS指标的参数设置为24日,将KD指标的参数设置为9;3;3。
 2. BIAS指标要小于-6,这只是确认该股超跌的初选条件。
 3. KD指标产生黄金交叉,K线上穿D线。
 4. KD交叉同时,KD指标中的D值要小于16。
 
BIAS3 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,colorff00ff;
 RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
 K:=SMA(RSV,3,1),COLORWHITE;
 D:=SMA(K,3,1),COLORYELLOW;
 xg:BIAS3<-6 and cross(k,d) and d<16;
 
7,要求是量大、换手率达到3左右,涨幅>7个点。
 xg:v/capital*100>3 and (c/ref(c,1)>1.07;
 
8,个股分时图上都有一条黄线,叫做均价线
 a/capital*100;
 
9,"阴转阳"的公式(也就是昨天收阴线,今天收阳线)
 xg:ref(c,1)<ref(o,1) and c>o;

 10,股价回抽20日均线选股公式
 
xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c);
 

 

11,一根大阳线,至少有5个点以上,再连着出现二根振幅不大于5的十字星或是小K线
 
xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05 and count((h-l)/l<0.05,2)=2;
 

 

12,行情信息里的“涨幅”的原码
 
(c-ref(c,1))/c*100;
 

 

13,kdj的J从上向下穿越O轴发出信号
 
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
 K:=SMA(RSV,3,1),COLORWHITE;
 D:=SMA(K,3,1),COLORYELLOW;
 J:=3*K-2*D,COLORFF00FF;
 xg:cross(0,j);
 

14,股价4天中有两天在10日线上
 
count(c>ma(c,10),4)=2;
 

 

15,选出10天内出现了涨停的个股
 
count(c/ref(c,1)>1.1,10)>0;
 

 

又:
 
今涨停:=C/REF(C,1)>1.09;
 选股:count(今涨停,n);
 

16,一阳上穿10,20,30日线,量能是前一天3倍。
 
xg:cross(c,ma(c,10)) and cross(c,ma(c,20)) and cross(c,ma(c,30)) and v>ref(v,1)*3;
 

 

17,共三根K线,第一根K线为阴线;第二根K线为阴线线,最高价低于第一根K线,最低价高于第一根K线;第三根K线阴阳不限,最高价低于第二根K线,最低价高于第二根K线。满足后发出信号~
 

w1:=ref(c,2)<ref(o,2);
 w2:=ref(h,2)>ref(h,1) and ref(l,2)<ref(l,1);
 w3:=ref(h,1)>h and ref(l,1)<l;
 xg:w1 and w2 and w3;
 

18, 选出今日成交量大于昨日成交量一成的股票
 
xg:v>ref(v,1)*1.1;
 

19, 连续5天,当日的5日均线减前一天的5日均线差值小于1.
 
count((ma(c,5)-ref(ma(c,5),1))<1,5)=5;
 

20,股价上穿5周均线:
 xg:cross(c,ma(c,5));
 注意:选股时用周线
 

 

21,上穿30日均线的公式
 xg:cross(c,ma(c,30));
 

22,两笔阴线中间夹着一根阳线或数根K线,其中两笔阴线最低点相等
 xg:ref(l,2)=l;
 

23,量比大于1 同时换手大于2的公式
 xg:v/ref(v,1)>1 and AMOUNT/CAPITAL*100>2;
 

24,换手:VOL*100/CAPITAL;
 周期换手:SUM(换手,10);
 

25,流通盘小于4000万 的选股公式
 
xg:CAPITAL/100<4000;
 

26,涨停开盘跌停收盘选股
 
xg:h/ref(c,1)>1.1 and ref(c,1)/l>1.1;
 

27,当天开盘价与收盘价相等的选股公式
 
xg:c=o;
 

28,5日均线向上 流通盘小于5000万 换手率大于3的选股公式
 
lt:CAPITAL/100<5000;
 换手:=VOL*100/CAPITAL<3;
 w1:ma(c,5)>ref(ma(c,5),1);
 xg:lt and 换手 and w1;
 

 

29,收下影线
 
xg:c>l;
 

30, o=l就没有下引线了,那就:
 xg:c>l and o>l;
 

31,当日收盘下穿5日均价
 
xg:cross(ma(c,5),c);
 

32,最低价小于前一日的最低价但收盘后为阳线。
 xg:l<ref(l,1) and c>o;
 

33,30日内到本日收盘价下跌20%的公式
 
xg:hhv(c,30)/c>1.2;
 

34,选周线跳空缺口的个股。
 
xg:HIGH<REF(LOW,1) OR
 LOW>REF(HIGH,1);
 周期选周线
 

35,30日均线走平或走高的个股
 
xg:ma(c,30)>ref(ma(c,30),1);
 

36,连续4天的收盘价格波动幅度在3%之内连续走平或向上
 count(abs(c-ref(c,1)/ref(c,1))<0.03 and c>ref(c,1),3)=3;
 

37,下影线长于上影线
 
(c-l)>(h-c);
 

38, 收盘价+收盘价的10%
 (c+c*0.1);
 

39,今天高开的公式
 c>o;
 

40,今天的量大于等于昨天量的2倍,股价上涨
 xg:v>ref(v,1)*2 and c>ref(c,1);
 

41,今天的量小于昨天量的2倍以上,股价上涨
 xg:v<ref(v,1)*2 and c>ref(c,1);
 

42,大部分股票跌到43日均线时就会反弹,如果在43日均线附近买入,短线成功率占90%以上,即时选出还差几分钱就跌到43日均线的股票
 
xg:abs(c-ma(c,43))/ma(c,43)<0.01;
 


43,{选出每天换手5%-15%之间的股票}
 
Var1:=100*VOL/CAPITAL;
 w1:=var1>5;
 w2:=var1<15;
 xg:w1 and w2;
 

44,换手率10天80%以上的选股公式
 sum(VOL/CAPITAL*100,10)>80;
 

45,60个交易日内,涨幅大于9.9%(涨停)的天数
 
count(c/ref(c,1)>1.099,60);
 

46,昨天跌幅大于3%,今天开盘高开2%以上的选股公式。
 
xg:ref(c,1)/ref(c,2)<0.97 and o/ref(c,1)>1.02;
 

47,选出周换手率小于10%的股票
 sum(VOL/CAPITAL*100,5)<10;
 

48,成交量创20日新低,并且股价也创20日新低
 
xg:v=llv(v,20) and c=llv(c,20);
 

49,5日不涨,绿线收盘选票指标
 
count(c<o,5)=5;
 

50,"今日MACD等于昨天的MACD ,且macd>0" 的指标
 
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
 DEA:=EMA(DIFF,9);
 MACD:=2*(DIFF-DEA);
 xg:macd=ref(macd,1) and macd>0
 

51,连续2天收盘价跌破30日均线,就显示"卖出"信号
 
a1:count(c<ma(c,30),2)=2;
 drawtext(a1,c,'卖出'),colorgreen;
 

52,股票在这条均线上在8天以上,上下幅度不大,
 
a1:abs((c-ma(c,120))/ma(c,120))<0.1;
 xg:count(a1,8)=8;
 

53, 连续三天高开高走的选股公式
 
count(o>ref(c,1) and c>o,3)=3;
 

54,n天内曾经有m个涨停
 
count(c/ref(c,1)>1.09,n)>m;
 

55,股价比昨天的高,量比昨天小,放量。
 xg:c>ref(c,1) and v<ref(v,1) and ref(v,1)>ref(v,2)*2;
 

56,连续3天每天的最低价都比前一天高
 
count(l>ref(c,1),3)=3;
 

57,周量缩小50%或40%或n%
 a1:vol/capital*100;
 xg:a1/ref(a1,1)<n/100;
 

58,股价超过五日均价的15%以上,并给出卖出信号
 
卖出:c/ma(c,5)>1.15;
 

59,连收两个十字星的选股公式
 
count(abs((c-o)/o<0.01),2)=2;
 

60,n横盘天数,n1横盘的上下幅度
 
REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(n1/100)
 and ref(v,1)<ref(ma(v,5),1) and cross(v,ma(v,5)) and cross(v,ma(v,10));
 

 


61,收盘价连续8天都站在5日均线的股票
 
count(c>ma(c,5),8)=8;
 

62,振幅大于5%,收盘价大于3.5小于15元,三日均线大于昨日的三日均线,去掉ST股。
 
a1:=h/l>1.05;
 a2:=c>3.5 and c<15;
 a3:=ma(c,3)>ref(ma(c,3),1);
 xg:a1 and a2 and a3;
 

63,收盘价下有60天前的远期获利盘n%。
 {60天前的远期获利盘:=ppart(60)*100;}
 

aa:WINNER(ref(c,60 ))*100;
 

64,连续三日收阳 后日收盘高于前日 且每日收于当日最高价附近 每日涨幅不大于4%
 选股:count(c>o and c>ref(c,1) and abs((h-c)/c)<0.01 and c/ref(c,1)<1.04,3)=3;
 

65,昨日收阴, 今日收阳,的K线组合。
 
C>O AND REF(C,1)<REF(O,1);
 

66,股价突破5ma买入,跌破5ma卖出。买入和卖出用箭头表示 (副图)
 
a1:cross(c,ma(c,5));
 a2:cross(ma(c,5),c);
 drawtext(a1,low*0.98,'↑'),colorred;
 drawtext(a2,h*1.02,'↑'),color00ffff;
 

67,今天的250平均线大于昨天的昨天的250平均线
 ma(c,250)>ref(ma(c,250),1);
 

68,历史高点到前一高点画线
 
POLYLINE(h>=hhv(c,0),h);
 

69,均线中增加一根线,这根线的价格是5日线的1.2倍
 
aa:ma(c,5)*1.2;
 

70,20天均线向上的股
 
xg:ma(c,20)>ref(ma(c,20),1);
 

71,连续3天收盘全是阴线。
 
count(c<ref(c,1),3)=3;
 

72,今天收盘价在昨天收盘价-2%~2%之间
 
c/ref(c,1)>0.98 and c/ref(c,1)<1.02;
 

73,收盘价在5日均线以上5天
 
count(c>ma(c,5),5)=5;
 

74,N天前换手率大于8%
 
REF(VOL/CAPITAL*100,N)>8;
 

75,一条均线18MA 股价上涨后“缩量”回调到18MA
 XG:COUNT(V<REF(V,1) AND C<O,N)=N AND C>MA(C,18);
 N “缩量”回调的天数
 

76,1。昨日量是n天以来最低量,(n可调);2。今日量是昨日量的m倍,(m可调);3。今日k线收阳线;
 xg:ref(v,1)=llv(ref(v,1),n) and v>ref(v,1)*m and c>o;
 

77,第一天收阴,第二天,第三天,第四天,收出红三兵
 
XG:REF(C,3)<REF(C,4) AND COUNT(C>O,3)=3;
 

78,月k线十字星收盘 并且5月线拐点向上。
 XG:ABS(C-O)/O<0.02 AND MA(C,5)>REF(MA(C,5),1);
 用月线选股
 

79,最近3天(包括昨天.前天)股价突破250日均线
 
COUNT(C>MA(C,250),3)=3;
 

80,跳高大阴线,条件: 1 开盘跳空4%以上2 大阴线实体6%以上.
 O/REF(C,1)>1.04 AND C/REF(C,1)<0.94;
 

81,条件:1: 假设大前天创最近新高,要求这天涨幅是超过7%的大阳线,且创最近一个月的新高.
 2: 那么前天,昨天,今天都收小K线,要求小K线实体
 
xg:ref(c,3)/ref(c,4)>1.07 and ref(c,3)=hhv(c,20) and count(abs((c-ref(c,1))/ref(c,1)<0.02,3)))=3;
 

 

82,60与120均线距离在n%内
 
XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;
 

83,5日均线倾角大于60度
 
X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;
 
也可以这样:
 
X:(ATAN((EMA(C,5)/REF(EMA(C,5),1)-1)*100)*180/3.14115926)>60;
 
利用指标排序:
 X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
 

84,“中阴之后,跳拉阳”
 c/ref(c,1)>1.05;
 

------------------------------------------------------------------------------------------------------
 
85,count(x,n) 意思是n天内出现过信号的,假设n=10,那么就是10天内出现信号(包括今天),如果不加这个的话,就是限定在今天出信号才选出来,以前的不管。
 

86, 今天涨停的公式
 C/REF(C,1)>1.09;
 


87,10日内有涨停的公式
 今涨停:=C/REF(C,1)>1.09;
 选股:count(今涨停,10);
 

88,昨日前日涨停的
 REF(C,1)/REF(C,2)>1.095;
 

89,近5日K线最高价和最低价格波动在10%以内,成交量是昨日2倍,收盘涨5%
 XG:(HHV(C,5)-LLV(C,5))/LLV(C,5)<0.1 AND V>REF(V,1)*2 AND C/REF(C,1)>1.05;
 

90,60与120均线距离在n%内
 XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;
 

91,“中阴之后,跳拉阳”
 c/ref(c,1)>1.05;
 

92,能在图上提示个股(不含S或ST股)出现过的涨跌停板日期的公式
 
w1:if((c-ref(c,1))/ref(c,1)>0.1,date-1000000,c);
 

93,涨幅≤2%
 (c-ref(c,1)/ref(c,1)*100<2;
 

94,5日,10日,30日贴近公式,越贴越好
 m1:=ma(close,5);
 m2:=ma(close,10);
 m3:=ma(close,20);
 m4:=ma(close,30);
 y1:=max(max(max(m1,m2),m3),m4);
 x1:=min(min(min(m1,m2),m3),m4);
 黏合:y1/x1<n;
 n越小越黏合(n,1.01-----1.05)
 

95,(1)换手率均线DMA(c ,v/CAPITAL );
 (2)20天以来的任意天期(n),换手率均线正负波动值<=p%;
 AA:=DMA(c ,v/CAPITAL );
 ab:=(aa-ref(aa,1))/ref(aa,1)*100<p;
 bb:count(ab,20)>=n;
 


96, 30天线拐头向上出现提示
 ma(c,30)>ref(ma(c,30),1);
 

97,今天的换手率大于前天的一倍以上
 w1:=v*100/capital;
 w1>ref(w1,2)*2;
 

98,K线沿着5日均线往上爬的选股公式
 w1:ma(c,5);
 w2:abc(c-w1)/w1<0.01;
 xg:count(w1>ref(w1,1),5)=5 and w2;
 

99,20日均线,上穿62日均线
 xg:cross(ma(c,20),ma(c,62));
 

100,平台整理的公式,整理时间和整理幅度可调
 COUNT(CLOSE,0)>N AND
 (HHV(CLOSE,N)-LLV(CLOSE,N))/LLV(CLOSE,N)<=(N1/100);
 N整理时间,N1整理幅度
 

101,选出当日收盘价突破10日均线5%的个股
 cross(c,ma(c,10)*1.05);
 

102,选出当日最低价在10日均线上下0.05%内,收盘价在均线上方的个股
 
abs(l-ma(c,10))<0.005 and c>ma(c,10);
 

103,第一天股票涨停,第二天成交量是第一天成交量的1倍,并超过10%.那第三天就是买点
 w1:=ref(c,2)/ref(c,3)>1.1;
 w2:=ref(v,1)/ref(v,2)>2;
 xg:w1 and w2;
 

104,放量2倍突破300日线的选股指标
 cross(c,ma(c,300)) and v>ref(v,1)*2;
 


105,3日均线上穿10日均线,KDJ有效金叉
 RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
 K:=SMA(RSV,3,1);
 D:=SMA(K,3,1);
 J:=3*K-2*D;
 w1:=cross(ma(c,3),ma(c,10));
 xg:w1 and cross(k,d);

 106,30日均线拐头向上ma(c,30)>ref(ma(c,30),1);

 107,连续3-5天,每天的收盘价涨跌幅不超过1%.w1:abs(c-o)<0.01;
 xg:count(w1,5)>=3;

 108,K线收十字星abs(c-o)/o<0.01;

 109,MACD在8天以内两次金叉DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
 DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
 MACD:=2*(DIFF-DEA);
 w1:cross(DIFF,dea);
 xg:count(w1,8)>=2;

 110,昨天升降幅在-n%----n%之间
 w1:abs(ref(c,1)-ref(c,2))/ref(c,2)*100<n;

 111,于20日均线相差2个百分点的
 w1:abs(c-ma(c,20)/ma(c,20)*100<2;
 N日均线相差M个百分点的公式.
 w1:abs(c-ma(c,n)/ma(c,n)*100<m;
 n:N日 m:M个百分点

 112,60MA由向下调头向上ma(c,60)>ref(ma(c,60),1);

 113, 股价回调到14日均线的选股 abs(c-ma(c,14))/ma(c,14)<0.005;

 114,历史第5根K线到第30根K线之间的最高价hhv(ref(c,5),25);

 115,MACD的拐点公式DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
 DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
 MACD:=2*(DIFF-DEA);
 拐点:ref(macd,2)>ref(macd,1) and ref(macd,1)<macd;

 116,跳空高开收阳线LOW>REF(HIGH,1) and c>o;

 117,涨停过300日线的选股公式
 c/ref(c,1)>1.09 and cross(c,ma(c,300));

 118,成交量是前5天中其他任何一天的10天均量线的3.5倍以上
 w1:=llv(ma(v,10),5);
 xg:v>w1*3.5;

 119,股价N天内连续沿着5天线走,且每天收盘价与5天线的距离不超过2%的选股
 公式
 w1:=abs(c-ma(c,5))/ma(c,5)<0.02;
 xg:count(w1,n)=n;

 120,跳空高开后,三天内没有回补缺口
 ref(LOW,2)>REF(HIGH,3) and l>ref(LOW,2);

 121,日涨幅小于3%C>0 AND C/REF(C,1) >1.03;

 122, 股价创30个交易日的新高H>ref(H,30);

 123,连续n天收阳线UP:=CLOSE>OPEN;
 COUNT(UP,N)=N;

 124, {5日内第二大量}
 zdl:=hhv(v,5);
 v0:=IF(v>=zdl,0,v);
 v1:=IF(ref(v,1)>=zdl,0,ref(v,1));
 v2:=IF(ref(v,2)>=zdl,0,ref(v,2));
 v3:=IF(ref(v,3)>=zdl,0,ref(v,3));
 v4:=IF(ref(v,4)>=zdl,0,ref(v,4));
 第二大量:MAX(MAX(MAX(MAX(v0,v1),v2),v3),v4);
 DRAWTEXTABS( 0,10 ,第一大量 + zdl+ 第二大量+第二大量);同理可求出第三大
 、第四大和最小量.实行简单的排列.
 这个公式好比是一件完整产品中的一个零部件,解决了一个思路问题.

 125,{5日均线倾角大于60度}
 X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
大智慧125个实用的选股公式 总有适合你的下载
查看全部评论     相关评论:
评论内容:
昵称: 验证码:验证码