未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股票内参 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 大智慧公式 > 正文
大智慧多空轨道主图源码加分时主图
  • 相关简介: 大智慧多空轨道主图源码加分时主图 X1:=HHV(H,3); X2:=LLV(L,3); XX:=(X1+X2)/2; XC:=C; XH:=H; XL:=L; LYA1:=IF (XHREF(X1,1) AND XCREF(XC,1),X2,IF (XLREF(X2,1) AND XCREF(XC,1),X1,0)); LYA:=IF(LYA1=0,REF(LYA1,1),LYA1); SNX2:=IF(LYAH AND LYAL,REF(LYA,1),LYA); 多空平衡:EMA(EMA(E
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境: 大智慧
  • 编辑发布: 股海网
  • 软件来源: www.guhai.com.cn
  • 加入时间: 2012/5/7 1:00:33
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

大智慧多空轨道主图源码加分时主图

X1:=HHV(H,3);
X2:=LLV(L,3);
XX:=(X1+X2)/2;
XC:=C;
XH:=H;
XL:=L;
LYA1:=IF (XH>REF(X1,1) AND XC>REF(XC,1),X2,IF (XL<REF(X2,1) AND XC<REF(XC,1),X1,0));
LYA:=IF(LYA1=0,REF(LYA1,1),LYA1);
SNX2:=IF(LYA<H AND  LYA>L,REF(LYA,1),LYA);
多空平衡:EMA(EMA(EMA(HIGH,7.23379625),7.23379625),1),COLORffffff;
强势回挡:多空平衡*0.9276620375,COLOR0080ff,LINETHICK1;
弱势反弹:多空平衡*0.868055,COLOR0000ff,LINETHICK1; {0.9}
最低安全:多空平衡*0.8263889,COLORff00ff,LINETHICK1;
高位止赢:多空平衡*1.12170138,COLOR00ff00,LINETHICK1;
获利了结:多空平衡*1.0723379625,COLORffff00,LINETHICK1;
超涨出货:多空平衡*1.1694444444,COLORff0000,LINETHICK1;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100 ;
STICKLINE(BIAS2<-6,H,L,0,0),COLORGREEN;
STICKLINE(BIAS2<-6,C,O,3,1),COLORGREEN;

DRAWTEXT(BARSTATUS=2,多空平衡,'平衡1.00'),COLORffffff;
DRAWTEXT(BARSTATUS=2,强势回挡,'回挡0.93'),COLOR0080ff;
DRAWTEXT(BARSTATUS=2,弱势反弹,'反弹0.87'),COLOR0000ff;
DRAWTEXT(BARSTATUS=2,最低安全,'安全0.83'),COLORff00ff;
DRAWTEXT(BARSTATUS=2,高位止赢,'止赢1.12'),COLOR00ff00;
DRAWTEXT(BARSTATUS=2,获利了结,'获利1.07'),COLORFFFF00;
DRAWTEXT(BARSTATUS=2,超涨出货,'超涨1.17'),COLORFF0000;

{红}
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8,0 ),COLOR000099;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,0 ),COLOR0000bb;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0 ),COLOR0000dd;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0 ),COLOR0000ff;
{蓝}
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,8,0 ),COLOR009900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,6,0 ),COLOR00bb00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,4,0 ),COLOR00dd00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2,0 ),COLOR00ff00;

DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
AMA1:=EMA(DMA(CLOSE,CQ1),2); 
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
AMA2:=EMA(DMA(CLOSE,CQ2),2);
PARTLINE(AMA2,AMA2/REF(AMA2,1)>0.997 and AMA2/REF(AMA2,1)<1.001,RGB(0,255,255),AMA2/REF(AMA2,1)>1.001,RGB(255,255,0),1,rgb(255,255,255)),LINETHICK3;

大智慧多空轨道主图源码加分时主图

指标可用于通达信分时主图,以方便实时决策,方法是:

建立引用文件"FSYY":
源码
比:=240/FROMOPEN;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);
今量:=买盘+卖盘;
差:=买盘-卖盘;
主买:=买盘;
昨量:=REF(VOL,1);
昨主:=REF(主买,1);
昨差:=REF(差,1);
前量:=REF(VOL,2);
前主:=REF(主买,2);
前差:=REF(差,2);
前4:=REF(VOL,3);
主4:=REF(主买,3);
差4:=REF(差,3);
前5:=REF(VOL,4);
主5:=REF(主买,4);
差5:=REF(差,4);
总5:=今量+昨量+前量+前4+前5;
总差:=差+昨差+前差+差4+差5;
YC:差;
SC:差+昨差+前差;
WC:总差;
SZJS:INDEXADV;
XDJS:INDEXDEC;
ZS:DYNAINFO(3);
XJ:DYNAINFO(7);
DKPH:EMA(EMA(EMA(HIGH,7.23379625),7.23379625),1),COLORRED;

再建立主图文件:

TBX:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-TBX)/TBX*100;
DFX:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
KFX:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,DFX,TBX,10,0),COLOR000066;
STICKLINE(A1X<0,KFX,TBX,10,0),COLOR006600;
NXX:EMA(C,120),COLOR0080FF,LINETHICK2;
DRAWTEXT(BARSTATUS=2,NXX,'<牛熊线'),COLOR0080FF;
最新:C,LINETHICK1,COLORWHITE;
IF(C>=REF(C,1),C,DRAWNULL),LINETHICK3,COLORRED;
AA:=SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C));
BB:=BETWEEN(C/AA,C+H,C-H);
DRAWICON(ISLASTBAR AND C>REF(C,1),C,1);
DRAWICON(ISLASTBAR AND C<REF(C,1),C,2);
SZJS:=IF(PERIOD=0 ,"FSYY.SZJS#DAY",DRAWNULL),NODRAW;
XDJS:=IF(PERIOD=0 ,"FSYY.XDJS#DAY",DRAWNULL),NODRAW;
YC:=IF(PERIOD=0 ,"FSYY.YC#DAY",DRAWNULL),NODRAW;
SC:=IF(PERIOD=0 ,"FSYY.SC#DAY",DRAWNULL),NODRAW;
WC:=IF(PERIOD=0 ,"FSYY.WC#DAY",DRAWNULL),NODRAW;
ZS:=IF(PERIOD=0 ,"FSYY.ZS#DAY",DRAWNULL),NODRAW;
XJ:=IF(PERIOD=0 ,"FSYY.XJ#DAY",DRAWNULL),NODRAW;
DKPH:IF(PERIOD=0 ,"FSYY.DKPH#DAY",DRAWNULL),NODRAW;
多空平衡:=DKPH;
强势回挡:=DKPH*0.9276620375;
弱势反弹:=DKPH*0.868055;
最低安全:=DKPH*0.8263889;
高位止赢:=DKPH*1.12170138;
获利了结:=DKPH*1.0723379625;
超涨出货:=DKPH*1.1694444444;
今阻①:=ZS*(1+0.191*0.1);
今阻②:=ZS*(1+0.382*0.1);
今阻③:=ZS*(1+0.618*0.1);
明阻①:=XJ*(1+0.191*0.1);
明阻②:=XJ*(1+0.382*0.1);
明阻③:=XJ*(1+0.618*0.1);
今撑①:=ZS*(1-0.191*0.1);
今撑②:=ZS*(1-0.383*0.1);
今撑③:=ZS*(1-0.618*0.1);
明撑①:=XJ*(1-0.191*0.1);
明撑②:=XJ*(1-0.382*0.1);
明撑③:=XJ*(1-0.618*0.1);
DRAWTEXT_FIX(1,0.1,0,0,STRCAT('今日阻力①',CON2STR(今阻①,2))),COLOR00FF00;
DRAWTEXT_FIX(1,0.4,0,0,STRCAT('今日阻力②',CON2STR(今阻②,2))),COLOR00FF00;
DRAWTEXT_FIX(1,0.7,0,0,STRCAT('今日阻力③',CON2STR(今阻③,2))),COLOR00FF00;
DRAWTEXT_FIX(1,0.1,1-0.95,0,STRCAT('明日阻力①',CON2STR(明阻①,2))),COLORFFFF00;
DRAWTEXT_FIX(1,0.4,1-0.95,0,STRCAT('明日阻力②',CON2STR(明阻②,2))),COLORFFFF00;
DRAWTEXT_FIX(1,0.7,1-0.95,0,STRCAT('明日阻力③',CON2STR(明阻③,2))),COLORFFFF00;
DRAWTEXT_FIX(1,0.1,1-0.9,0,STRCAT('今日支撑①',CON2STR(今撑①,2))),COLOR00FFFF;
DRAWTEXT_FIX(1,0.4,1-0.9,0,STRCAT('今日支撑②',CON2STR(今撑②,2))),COLOR00FFFF;
DRAWTEXT_FIX(1,0.7,1-0.9,0,STRCAT('今日支撑③',CON2STR(今撑③,2))),COLOR00FFFF;
DRAWTEXT_FIX(1,0.1,1-0.85,0,STRCAT('明日支撑①',CON2STR(明撑①,2))),COLORFF00FF;
DRAWTEXT_FIX(1,0.4,1-0.85,0,STRCAT('明日支撑②',CON2STR(明撑②,2))),COLORFF00FF;
DRAWTEXT_FIX(1,0.7,1-0.85,0,STRCAT('明日支撑③',CON2STR(明撑③,2))),COLORFF00FF;
DRAWTEXT_FIX(1,0.1,1-0.80,0,STRCAT('上涨家数 ',CON2STR(SZJS,0))),COLOR0000FF;
DRAWTEXT_FIX(1,0.4,1-0.80,0,STRCAT('下跌家数 ',CON2STR(XDJS,0))),COLOR00FF00;
DRAWTEXT_FIX(C>0,0.1,1-0.05,0,STRCAT('五日量差[手]  ',CON2STR(WC,0))),COLORFF00FF;
DRAWTEXT_FIX(C>0,0.4,1-0.05,0,STRCAT('三日量差[手]  ',CON2STR(SC,0))),COLORFF00FF;
DRAWTEXT_FIX(C>=0,0.7,1-0.05,0,STRCAT('当日量差[手]  ',CON2STR(YC,0))),COLORFF00FF;
DRAWTEXT_FIX(1,0.7,1-0.80,0,STRCAT('超涨出货 ',CON2STR(超涨出货,2))),COLORFF0000;
DRAWTEXT_FIX(C>0,0.1,1-0.1,0,STRCAT('多空平衡  ',CON2STR(多空平衡,2))),COLORFFFFFF;
DRAWTEXT_FIX(C>0,0.4,1-0.1,0,STRCAT('强势回挡  ',CON2STR(强势回挡,2))),COLOR00FFFF;
DRAWTEXT_FIX(C>=0,0.7,1-0.1,0,STRCAT('弱势反弹  ',CON2STR(弱势反弹,2))),COLOR0000FF;
DRAWTEXT_FIX(C>0,0.1,1-0.15,0,STRCAT('最低安全  ',CON2STR(最低安全,2))),COLORFF00FF;
DRAWTEXT_FIX(C>0,0.4,1-0.15,0,STRCAT('高位止赢  ',CON2STR(高位止赢,2))),COLOR00FF00;
DRAWTEXT_FIX(C>=0,0.7,1-0.15,0,STRCAT('获利了结  ',CON2STR(获利了结,2))),COLORFFFF00;
均价:IF(PERIOD=0 ,SUM(C*V,240)/SUM(V,240),DRAWNULL),COLORYELLOW;
 

大智慧多空轨道主图源码加分时主图

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
大智慧多空轨道主图源码加分时主图下载
精品股票公式