未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股票内参 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 飞狐公式 > 正文
飞狐MACD顶底钝化改通达信,能通过不显示钝化H指示,求大师帮忙!
  • 相关简介: DIF:EMA(CLOSE,12)-EMA(CLOSE,26); DEA:EMA(DIF,9); MACD:(DIF-DEA)*2,COLORSTICK; SWIFTK:='MACD.MACD' * REF('MACD.MACD',1)0; EARLYDAY_1:=BARSLAST(REF(SWIFTK,1)); EARLYDAY_2:=BARSLAST(REF(SWIFTK,2)); EARLYDAY_3:=BARSLAST(REF(SWIFTK,3)); EARLYDAY_4:=BARSLA
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境: 飞狐
  • 编辑发布: 股海网
  • 软件来源: Internet
  • 加入时间: 2018/1/13 8:09:08
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
 DEA:EMA(DIF,9);
 MACD:(DIF-DEA)*2,COLORSTICK;
 SWIFTK:='MACD.MACD' * REF('MACD.MACD',1)<0;
 EARLYDAY_1:=BARSLAST(REF(SWIFTK,1));
 EARLYDAY_2:=BARSLAST(REF(SWIFTK,2));
 EARLYDAY_3:=BARSLAST(REF(SWIFTK,3));
 EARLYDAY_4:=BARSLAST(REF(SWIFTK,4));
 EARLYDAY_5:=BARSLAST(REF(SWIFTK,5));
 CLOW_0:=REF(LLV(MIN(O,C),EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
 CLOW_1:=REF(LLV(MIN(O,C),EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
 CLOW_2:=LLV(MIN(O,C),EARLYDAY_1);
 DIFFLOW_0:=REF(LLV('MACD.DIFF',EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
 DIFFLOW_1:=REF(LLV('MACD.DIFF',EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
 DIFFLOW_2:=LLV('MACD.DIFF',EARLYDAY_1);
钝化L:=
 'MACD.MACD'<0 AND (
 (INTPART(DIFFLOW_2)-INTPART(DIFFLOW_1)>0 AND CLOW_1>CLOW_2) OR
 (INTPART(DIFFLOW_2)-INTPART(DIFFLOW_0)>0 AND CLOW_0>CLOW_2)
 );
结构L:=
 'MACD.MACD'<0 AND INTPART('MACD.DIFF')>REF(INTPART('MACD.DIFF'),1) AND (
 (INTPART(DIFFLOW_2)-INTPART(DIFFLOW_1)>0 AND CLOW_1>CLOW_2 AND INTPART('MACD.DIFF')>INTPART(DIFFLOW_2)) OR
 (INTPART(DIFFLOW_2)-INTPART(DIFFLOW_0)>0 AND CLOW_0>CLOW_2 AND INTPART('MACD.DIFF')>INTPART(DIFFLOW_2))
 );
 DRAWTEXT(钝化L,'MACD.DIFF','L');
 DRAWICON(结构L,'MACD.DIFF',4);
 CHIGH_0:=REF(HHV(MAX(O,C),EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
 CHIGH_1:=REF(HHV(MAX(O,C),EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
 CHIGH_2:=HHV(MAX(O,C),EARLYDAY_1);
 DIFFHIGH_0:=REF(HHV('MACD.DIFF',EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
 DIFFHIGH_1:=REF(HHV('MACD.DIFF',EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
 DIFFHIGH_2:=HHV('MACD.DIFF',EARLYDAY_1);
钝化H:=
 'MACD.MACD'>0 AND (
 (INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_1)<0 AND CHIGH_1<CHIGH_2) OR
 (INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_0)<0 AND CHIGH_0<CHIGH_2)
 );
结构H:=
 'MACD.MACD'>0 AND INTPART('MACD.DIFF')<REF(INTPART('MACD.DIFF'),1) AND(
 (INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_1)<0 AND CHIGH_1<CHIGH_2 AND INTPART('MACD.DIFF')<INTPART(DIFFHIGH_2)) OR
 (INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_0)<0 AND CHIGH_0<CHIGH_2 AND INTPART('MACD.DIFF')<INTPART(DIFFHIGH_2))
 );
 DRAWTEXT(钝化H,'MACD.DIFF'*1.02,'H'),COLORGREEN;
 DRAWICON(结构H,'MACD.DIFF',5),COLORGREEN;
 

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
飞狐MACD顶底钝化改通达信,能通过不显示钝化H指示,求大师帮忙!下载
精品股票公式