在线检测未来函数 | 股海网搜索 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股票内参 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 飞狐公式 > 正文 公式解密改编QQ:78858997 官方QQ群:75780250 | 最新资源 | 热门资源
飞狐自用雪狼主图源码 趋势量价一目了然
  • 相关简介: 飞狐自用雪狼主图源码 趋势量价一目了然 {股海网提供: www.guhai.com.cn } 参数N...5...2..300 C5:SMA(COST(50),5,1),COLORRED,POINTDOT; C8:SMA(COST(80),5,1),COLORGREEN,POINTDOT; C18:SMA(COST(18),5,1),COLORWHITE,POINTDOT; 雪:(SUM(C,N-1)+C)/N,linethick0,COLORRED; M5:EMA(C,5),COLORWHIT
  • 内容标签: 狐,雪狼主图,源码,趋势量价,一目了然
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境: 飞狐
  • 编辑发布: 股海网
  • 软件来源: www.guhai.com.cn
  • 加入时间: 2012/3/30 0:45:42
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

飞狐自用雪狼主图源码 趋势量价一目了然

{股海网提供:www.guhai.com.cn}

参数N...5...2..300
 C5:SMA(COST(50),5,1),COLORRED,POINTDOT;
C8:SMA(COST(80),5,1),COLORGREEN,POINTDOT;
 C18:SMA(COST(18),5,1),COLORWHITE,POINTDOT;
雪:(SUM(C,N-1)+C)/N,linethick0,COLORRED;
 M5:EMA(C,5),COLORWHITE;
 M15:EMA(C,15),COLORYELLOW;
 M60:EMA(C,60),COLORGREEN;
 M240:EMA(C,240),COLORCYAN;
 {M220:MA(C,220),COLORGRAY;
 M440:MA(C,440),COLORBLUE;}
 A15:=BACKSET(ISLASTBAR,15);
 STICKLINE(REF(A15,1)=0 AND A15,HHV(H,30),LLV(L,30),0,0),COLORYELLOW;
 A30:=BACKSET(ISLASTBAR,30);
 STICKLINE(REF(A30,1)=0 AND A30,HHV(H,30),LLV(L,30),0,0),COLORYELLOW;
 A60:=BACKSET(ISLASTBAR,60);
 STICKLINE(REF(A60,1)=0 AND A60,HHV(H,30),LLV(L,30),0,0),COLORYELLOW;
 A220:=BACKSET(ISLASTBAR,220);
 STICKLINE(REF(A220,1)=0 AND A220,HHV(H,30),LLV(L,30),0,0),COLORYELLOW;
 AABB:=CROSS(MA(C,3),MA(C,8)) AND MA(C,8)>REF(MA(C,8),1) ;
 STICKLINE(AABB AND datatype>6,L,L*0.990,6,0),COLORYELLOW;
 AABB1:=CROSS(MA(C,50),MA(C,60)) AND MA(C,60)>REF(MA(C,60) ,1) ;
 ASZ:=MA(C,60)>REF(MA(C,60) ,1) AND MA(C,50)>REF(MA(C,50) ,1);AABB2:=REF(ASZ,1)=0 AND ASZ ;
 STICKLINE((AABB1 OR AABB2) AND MA(C,5)<MA(C,220) AND MA(C,5)>MA(C,60) AND datatype>6,L,L*0.90,6,0),COLORBLUE;
 {阻力:IF(PERIOD>4,0.998*"KX.HH#MONTH",IF(PERIOD>1,0.998*"KX.HH#WEEK",0.998*"KX.HH#DAY")),COLORGREEN;
 支撑:IF(PERIOD>4,1.002*"KX.LL#MONTH",IF(PERIOD>1,1.002*"KX.LL#WEEK",1.002*"KX.LL#DAY")),COLORYELLOW;};
 TY:=C;
 A1:=REF(TY,10)=HHV(TY,2*10+1); VB1:=FILTER(A1,10); C1:=BACKSET(VB1,10+1); HD:=FILTER(C1,10);
 A2:=REF(TY,10)=LLV(TY,2*10+1); VB2:=FILTER(A2,10); C2:=BACKSET(VB2,10+1); LD:=FILTER(C2,10);
 A:=REF(H,BARSLAST(HD)); B:=REF(L,BARSLAST(LD));
 T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
 T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
 波峰:IF(T1,A,A),COLORFF00FF,POINTDOT;
 STICKLINE(T1,A,A,9,0),COLORFF00FF;
 波谷:IF(T2,B,B),COLOR80FF00,POINTDOT;
 STICKLINE(T2,B,B,9,0),COLOR80FF00;
 fh:=HIGH;fl:=LOW;
 DRAWTEXTEX(sysparam(3)=BARPOS,0,10,8,'【代码:'+STKLABEL+' 名称:'+STKNAME+'】'),COLORWHITE;
 DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH,('所属板块:' + BLKNAME)+ '\n')ALIGN4,COLORGREEN;
 variable:wday[7]='星期六';
 wday[1]:='星期日';
 wday[2]:='星期一';
 wday[3]:='星期二';
 wday[4]:='星期三';
 wday[5]:='星期四';
 wday[6]:='星期五';
 fy:=year;
 fm:=month;
 fd:=day;
 wd:=weekday;
 p:=SYSPARAM(1);
 DRAWTEXTex(c,0,300,1,
 numtostr(fy[p],0)+'年'+numtostr(fm[p],0)+'月'
 +numtostr(fd[p],0)+'日,'+wday[wd[p]+1]+'\n'),COLORyellow;
 DRAWTEXTEX(1,1,20,150,'雪
狼 提 醒 顺 上 飞'),COLORRED;
 STICKLINE((CLOSE < OPEN),HIGH,LOW,1,0),color8800;
 STICKLINE((CLOSE < OPEN),HIGH,LOW,0,0),colorFF00;
 STICKLINE((CLOSE < OPEN),CLOSE,OPEN,8,0),color8800;
 STICKLINE((CLOSE < OPEN),CLOSE,OPEN,7,0),color9900;
 STICKLINE((CLOSE < OPEN),CLOSE,OPEN,6,0),colorAA00;
 STICKLINE((CLOSE < OPEN),CLOSE,OPEN,5,0),colorBB00;
 STICKLINE((CLOSE < OPEN),CLOSE,OPEN,4,0),colorCC00;
 STICKLINE((CLOSE < OPEN),CLOSE,OPEN,3,0),colorDD00;
 STICKLINE((CLOSE < OPEN),CLOSE,OPEN,2,0),colorEE00;
 STICKLINE((CLOSE < OPEN),CLOSE,OPEN,1,0),colorFF00;
 STICKLINE((CLOSE >= OPEN),HIGH,LOW,1,0),colorFF;
 STICKLINE((CLOSE >= OPEN),HIGH,LOW,0,0),colorEEFF;
 STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),colorFF;
 STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color22FF;
 STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color44FF;
 STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color66FF;
 STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),color88FF;
 STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),colorAAFF;
 STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),colorCCFF;
 STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),colorEEFF;
 {立体柱子:红色}{股海网提供:www.guhai.com.cn}
 STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000033;
 STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
 STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
 STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000BB;
 STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000DD;
 VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF (C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2) =HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3) =HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
 红持:var9Q,color0000ff,LINETHICK0;
 {立体柱子:红色}
 STICKLINE(VAR9Q,C,(O+C)/2,8,0),COLOR000044;
 STICKLINE(VAR9Q,C,(O+C)/2,7,0),COLOR000055;
 STICKLINE(VAR9Q,C,(O+C)/2,6,0),COLOR000066;
 STICKLINE(VAR9Q,C,(O+C)/2,5,0),COLOR000077;
 STICKLINE(VAR9Q,C,(O+C)/2,4,0),COLOR000099;
 STICKLINE(VAR9Q,C,(O+C)/2,3,0),COLOR0000BB;
 STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR0000DD;
 STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000FF;
 VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
 粉变:varaQ,colorff99ff,LINETHICK0;
 STICKLINE(VARAQ,C,(O+C)/2,8,0),COLORFF11FF;
 STICKLINE(VARAQ,C,(O+C)/2,7,0),COLORFF22FF;
 STICKLINE(VARAQ,C,(O+C)/2,6,0),COLORFF33FF;
 STICKLINE(VARAQ,C,(O+C)/2,5,0),COLORFF55FF;
 STICKLINE(VARAQ,C,(O+C)/2,4,0),COLORFF77FF;
 STICKLINE(VARAQ,C,(O+C)/2,3,0),COLORFF99FF;
 STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORFFBBFF;
 STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFFDDFF;
 VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
 银灰跌:varbQ,color888888,LINETHICK0;
 {立体柱子:银色}
 STICKLINE(VARBQ,C,(O+C)/2,8,0),COLOR333333;
 STICKLINE(VARBQ,C,(O+C)/2,7,0),COLOR444444;
 STICKLINE(VARBQ,C,(O+C)/2,6,0),COLOR555555;
 STICKLINE(VARBQ,C,(O+C)/2,5,0),COLOR777777;
 STICKLINE(VARBQ,C,(O+C)/2,4,0),COLOR999999;
 STICKLINE(VARBQ,C,(O+C)/2,3,0),COLORBBBBBB;
 STICKLINE(VARBQ,C,(O+C)/2,2,0),COLORDDDDDD;
 STICKLINE(VARBQ,C,(O+C)/2,1,0),COLORFFFFFF;
 VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
 绿买:varcQ,color00ff00,LINETHICK0;
 {立体柱子:绿色}
 STICKLINE(VARCQ,O,(O+C)/2,8,0),COLOR004400;
 STICKLINE(VARCQ,O,(O+C)/2,6,0),COLOR005500;
 STICKLINE(VARCQ,O,(O+C)/2,5,0),COLOR007700;
 STICKLINE(VARCQ,O,(O+C)/2,4,0),COLOR009900;
 STICKLINE(VARCQ,O,(O+C)/2,3,0),COLOR00BB00;
 STICKLINE(VARCQ,O,(O+C)/2,2,0),COLOR00DD00;
 STICKLINE(VARCQ,O,(O+C)/2,1,0),COLOR00FF00;
 VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF (C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
 蓝抛:vardQ,colorff9900,LINETHICK0;
 {立体柱子:深蓝色}
 STICKLINE(VARDQ,O,(O+C)/2,8,0),COLORFF1100;
 STICKLINE(VARDQ,O,(O+C)/2,7,0),COLORFF2200;
 STICKLINE(VARDQ,O,(O+C)/2,6,0),COLORFF3300;
 STICKLINE(VARDQ,O,(O+C)/2,5,0),COLORFF5500;
 STICKLINE(VARDQ,O,(O+C)/2,4,0),COLORFF7700;
 STICKLINE(VARDQ,O,(O+C)/2,3,0),COLORFF9900;
 STICKLINE(VARDQ,O,(O+C)/2,2,0),COLORFFBB00;
 STICKLINE(VARDQ,O,(O+C)/2,1,0),COLORFFDD00;
 {立体柱子:金色}
 ZDF:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
 STICKLINE(ZDF>9.8,OPEN,CLOSE,8,0),color004444;
 STICKLINE(ZDF>9.8,OPEN,CLOSE,7,0),color005555;
 STICKLINE(ZDF>9.8,OPEN,CLOSE,6,0),color006666;
 STICKLINE(ZDF>9.8,OPEN,CLOSE,5,0),color007777;
 STICKLINE(ZDF>9.8,OPEN,CLOSE,4,0),color009999;
 STICKLINE(ZDF>9.8,OPEN,CLOSE,3,0),color00BBBB;
 STICKLINE(ZDF>9.8,OPEN,CLOSE,2,0),color00DDDD;
 STICKLINE(ZDF>9.8,OPEN,CLOSE,1,0),color00FFFF;
 Z:=(CLOSE > REF(CLOSE,1));
 成功:((((((((((((((((((((((((((((((ALL(Z,1) + ALL(Z,2)) +
 ALL(Z,3)) + ALL(Z,4)) + ALL(Z,5)) + ALL(Z,6)) + ALL(Z,7)) +
 ALL(Z,8)) + ALL(Z,10)) + ALL(Z,11)) + ALL(Z,12)) + ALL(Z,13)) +
 ALL(Z,14)) + ALL(Z,15)) + ALL(Z,16)) + ALL(Z,17)) + ALL(Z,18)) +
 ALL(Z,19)) + ALL(Z,20)) + ALL(Z,21)) + ALL(Z,22)) + ALL(Z,23)) +
 ALL(Z,24)) + ALL(Z,25)) + ALL(Z,26)) + ALL(Z,27)) + ALL(Z,28)) +
 ALL(Z,29)) + ALL(Z,30)) + ALL(Z,31)) + ALL(Z,32)),LINETHICK0,colorFF;
 D:=(CLOSE < REF(CLOSE,1));
 失败:((((((((((((((((((((((((((((((ALL(D,1) +
 ALL(D,2)) + ALL(D,3)) + ALL(D,4)) + ALL(D,5)) +
 ALL(D,6)) + ALL(D,7)) + ALL(D,8)) + ALL(D,10)) +
 ALL(D,11)) + ALL(D,12)) + ALL(D,13)) + ALL(D,14)) +
 ALL(D,15)) + ALL(D,16)) + ALL(D,17)) + ALL(D,18)) +
 ALL(D,19)) + ALL(D,20)) + ALL(D,21)) + ALL(D,22)) +
 ALL(D,23)) + ALL(D,24)) + ALL(D,25)) + ALL(D,26)) +
 ALL(D,27)) + ALL(D,28)) + ALL(D,29)) + ALL(D,30)) +
 ALL(D,31)) + ALL(D,32)),LINETHICK0,colorFF00;
 XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
 XL3:=CROSS(XL2,(0 - 20));
 {缺 口1}
 DRAWTEXT(l>REF(H,1),REF(H,1),''),COLOrwhite;
 DRAWTEXT(h<REF(L,1),REF(L,1),''),COLORblue;
 {缺 口2}
 KOH:=LOW>REF(HIGH,1);
 KOL:=HIGH<REF(LOW,1);
 HIF:=LOW>REF(HIGH,BARSLAST(KOH)+1);
 NHIF:=LOW<=REF(HIGH,BARSLAST(KOH)+1);
 LIF:=HIGH<REF(LOW,BARSLAST(KOL)+1);
 NLIF:=HIGH>=REF(LOW,BARSLAST(KOL)+1);
 DRAWICON(HIF AND BARSLAST(koh)<BARSLAST(nhif) and

BARSLAST(HIF)<BARSLAST(NHIF),REF(HIGH,BARSLAST(KOH)+1),10),ALIGN0;
 DRAWICON(LIF AND BARSLAST(kol)<BARSLAST(nlif) and

BARSLAST(LIF)<BARSLAST(NLIF),REF(LOW,BARSLAST(KOL)+1),11),ALIGN0;
 AABB:CROSS(MA(C,3),MA(C,8)) ,linethick0 ;
 STICKLINE(AABB AND datatype>5,L,L*0.990,6,0),COLORYELLOW;

{股海网提供:www.guhai.com.cn}

飞狐自用雪狼主图源码 趋势量价一目了然

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
飞狐自用雪狼主图源码 趋势量价一目了然下载