未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股海绝技 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 通达信公式 > 正文
通达信独霸牛熊公式源码
  • 相关简介: VAR1:=PERIOD=5 AND CLOSE0 AND VOL1; VAR2:=1; VAR3:=EMA(EMA(CLOSE,9),9); VAR4:=(VAR3-REF(VAR3,1))/REF(VAR3,1)*1000; VAR5:=EMA(EMA(CLOSE,8),8); VAR6:=(VAR5-REF(VAR5,1))/REF(VAR5,1)*1000; VAR7:=VAR60; VAR8:=VAR6=0; VAR9:=EMA(CLOSE,2); VAR10:=EMA(SLOPE(C
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境: 通达信
  • 编辑发布: 股海网
  • 软件来源: Internet
  • 加入时间: 2018/11/9 7:11:44
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

VAR1:=PERIOD=5 AND CLOSE>0 AND VOL>1;

VAR2:=1;

VAR3:=EMA(EMA(CLOSE,9),9);

VAR4:=(VAR3-REF(VAR3,1))/REF(VAR3,1)*1000;

VAR5:=EMA(EMA(CLOSE,8),8);

VAR6:=(VAR5-REF(VAR5,1))/REF(VAR5,1)*1000;

VAR7:=VAR6>0;

VAR8:=VAR6<=0;

VAR9:=EMA(CLOSE,2);

VAR10:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);

VAR11:=CROSS(VAR9,VAR10);

VAR12:=CROSS(VAR10,VAR9);

VAR13:=IF(VAR11 AND VAR7,1,IF(COUNT(VAR11 AND VAR8,BARSLAST(VAR12)+1)=1 AND CROSS(VAR6,0),1,0));

VAR14:=VAR13 AND COUNT(VAR13,BARSLAST(VAR12)+1)=1;

VAR15:=VAR12 AND COUNT(VAR12,BARSLAST(VAR14)+1)=1;

VAR16:=VAR14;

VAR17:=CLOSE/REF(OPEN,BARSLAST(VAR14))<1-7/100 AND COUNT(VAR14,BARSLAST(VAR14)+1)=1 AND COUNT(VAR15,BARSLAST(VAR14)+1)=0;

VAR18:=IF(VAR17 AND COUNT(VAR17,BARSLAST(VAR14)+1)=1,1,IF(VAR15 AND COUNT(VAR17,BARSLAST(VAR14)+1)=0,1,0));

VAR19:=COUNT(VAR17,BARSLAST(VAR16)+1)>=1 AND CROSS(CLOSE,0.965*REF(OPEN,BARSLAST(VAR16)));

VAR20:=(VAR19 AND VAR18)=0;

VAR21:=VAR16 AND COUNT(VAR18,VAR2)=0 OR VAR19 AND VAR20;

VAR22:=CLOSE/REF(OPEN,BARSLAST(VAR19))<1-7/100 AND COUNT(VAR19,BARSLAST(VAR19)+1)=1 AND COUNT(VAR15,BARSLAST(COUNT(VAR19,BARSLAST(VAR19)+1))+1)=0;

VAR23:=VAR15 AND COUNT(VAR19,BARSLAST(VAR21)+1)=1 OR (VAR22 AND SUM(VAR22,0)=1);

VAR24:=(VAR23 AND VAR21)=0;

VAR25:=VAR18 AND COUNT(VAR18,BARSLAST(VAR21)+1)=1 OR VAR23 AND VAR24;

VAR26:=VAR21 AND COUNT(VAR21,BARSLAST(VAR25)+1)=1;

VAR27:=VAR25 AND COUNT(VAR25,BARSLAST(VAR26)+1)=1;

VAR28:=IF(COUNT(VAR27,BARSCOUNT(CLOSE))=0 AND COUNT(VAR26,BARSCOUNT(CLOSE))=0,1,0);

VAR29:=VAR28 AND CROSS(VAR4,0);

VAR30:=IF(VAR28,VAR29,VAR26);

VAR31:=VAR30 AND VAR1;

VAR32:=MA(CLOSE,5);

VAR33:=MA(CLOSE,10);

VAR34:=MA(CLOSE,30);

VAR35:=MA(CLOSE,60);

VAR36:=EMA(CLOSE,5);

VAR37:=EMA(CLOSE,6);

VAR38:=DRAWLINE(LOW=LLV(LOW,BARSLAST(CROSS(VAR37,VAR36))+1),LLV(LOW,BARSLAST(CROSS(VAR37,VAR36))+1),HIGH=HHV(HIGH,BARSLAST(CROSS(VAR36,VAR37))+1),HHV(HIGH,BARSLAST(CROSS(VAR36,VAR37))+1),0);

VAR39:=(2*CLOSE+HIGH+LOW)/4;

VAR40:=LLV(VAR39,21);

VAR41:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR42:=REF(VAR41,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR43:=REF(VAR42,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR44:=REF(VAR43,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR45:=REF(VAR44,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR46:=REF(VAR45,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR47:=REF(VAR46,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR48:=REF(VAR47,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR49:=REF(VAR48,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR50:=REF(VAR49,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR51:=REF(VAR50,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR52:=REF(VAR51,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR53:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VAR54:=REF(VAR53,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR55:=REF(VAR54,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR56:=REF(VAR55,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR57:=REF(VAR56,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR58:=REF(VAR57,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR59:=REF(VAR58,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR60:=REF(VAR59,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR61:=REF(VAR60,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR62:=REF(VAR61,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR63:=REF(VAR62,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR64:=REF(VAR63,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR65:=REF(VAR53 OR VAR54 OR VAR55 OR VAR56 OR VAR57 OR VAR58 OR VAR59 OR VAR60 OR VAR61 OR VAR62 OR VAR63 OR VAR64,1) AND VAR41;

VAR66:=REF(VAR41 OR VAR42 OR VAR43 OR VAR44 OR VAR45 OR VAR46 OR VAR47 OR VAR48 OR VAR49 OR VAR50 OR VAR51 OR VAR52,1) AND VAR53;

VAR67:=(HIGH+LOW+CLOSE)/3;

VAR68:=VOL/IF(HIGH=LOW,4,HIGH-LOW);

VAR69:=ABS(VAR68*(VAR67-MIN(CLOSE,OPEN)));

VAR70:=ABS(VAR68*(MIN(OPEN,CLOSE)-LOW));

VAR71:=VAR69;

VAR72:=-VAR70;

VAR73:=VAR71-ABS(VAR72)>VAR71*0.5;

XG:VAR73 AND VAR38 AND VAR65 OR (VAR73 AND VAR38 AND VAR31);

通达信独霸牛熊公式源码

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
通达信独霸牛熊公式源码下载
精品股票公式