未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股海绝技 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 通达信公式 > 正文
通达信很好的MACD+KDJ指标公式
  • 相关简介: 底部:=-10; RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100); 短期底部:=LLV(OPEN,30); K:SMA(RSV,3,1); D:SMA(K,3,1); J:((3 * K) - (2 * D)); DRAWICON(FILTER(CROSS(K,D)AND K50,5),0.1,5); AA10:=MA(CLOSE,10); AA12:=MA(CLOSE,12); BB10:=((ATAN((AA1
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境: 通达信
  • 编辑发布: 股海网
  • 软件来源: Internet
  • 加入时间: 2019/1/11 8:20:27
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

底部:=-10;
 RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
短期底部:=LLV(OPEN,30);
 K:SMA(RSV,3,1);
 D:SMA(K,3,1);
 J:((3 * K) - (2 * D));
 DRAWICON(FILTER(CROSS(K,D)AND K<50,5),0.1,5);
 AA10:=MA(CLOSE,10);
 AA12:=MA(CLOSE,12);
 BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
 BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
 MA13:=MA(CLOSE,13);
 IF((K > D),K,DRAWNULL),COLORFF00FF;
 IF((K < D),K,DRAWNULL),COLORFFFF00;
 IF((J > D),J,DRAWNULL),LINETHICK2,COLORRED;
 IF((J < D),J,DRAWNULL),LINETHICK2,COLORGREEN;
 20,POINTDOT,COLORGREEN;
 80,POINTDOT,COLORGREEN;
 VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
 VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
 VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
 VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);
 VAR6:=MA(VAR5,3);
底部1:IF((VAR6 < 底部),20,0),COLORFFFF00;
 STICKLINE((CROSS(J,K) AND (底部1 >= 20)),100,0,2,0),COLORFFFFFF;
 DRAWICON((CROSS(J,K) AND (底部1 >= 20)),100,1);
 DRAWTEXT((CROSS(J,K) AND (底部1 >= 20)),98,'--全仓');
STICKLINE((VAR6 <= (0 - 15)),80,4.88,2,0);
 DRAWTEXT((VAR6 <= (0 - 15)),80,'买'),COLORFFFFFF;
 STICKLINE((VAR6 <= (0 - 15)),80,60,2,0),COLORRED;
 VAR7:=DMA(EMA(CLOSE,12),((SUM(VOL,5) / 3)));
 VAR8:=(((CLOSE - VAR7) / VAR7) * 100);
 VAR9:=((((REF(VAR8,1) < (0 - 40)) AND (VAR8 > REF(VAR8,1))) AND (REF(VAR8,1) < REF(VAR8,2))) AND ((VAR8 - REF(VAR8,1)) > 2.5));
 VARA:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
 VARB:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
 VARC:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
 VARD:=REF(CLOSE,1);
 VARE:=((SMA(MAX((CLOSE - VARD),0),5,1) / SMA(ABS((CLOSE - VARD)),5,1)) * 100);
 VARF:=(((HIGH + LOW) + CLOSE) / 3);
 VAR10:=((VARF - MA(VARF,14)) / (0.015 * AVEDEV(VARF,14)));
 VAR11:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273));
 VAR12:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));
 VAR13:=(VAR11 AND VAR12);
 VAR14:=((((VARA >= (0 - 45)) AND (VARA <= (0 - 10))) AND (VARB <= (0 - 15))) AND (VARC <= (0 - 20)));
 VAR15:=(COUNT(VAR14,1) >= 1);
 VAR16:=(VAR13 AND VAR15);
 VAR17:=1;
 VAR18:=(CLOSE * VOL);
 VAR19:=EMA((((((MA(VAR18,4) / MA(VOL,4)) + (MA(VAR18,6) / MA(VOL,6))) + (MA(VAR18,13) / MA(VOL,13))) + (MA(VAR18,24) / MA(VOL,24))) / 4),1);
 VAR1A:=(1 * VAR19);
 VAR1B:=(VAR19 * 0.92);
 VAR1C:=EMA(CLOSE,34);
 VAR1D:=MA((VAR1C * 1.12),5);
 VAR1E:=MA((VAR1C * 0.82),5);
 VAR1F:=(CLOSE < VAR1E);
 VAR20:=((((((MA(AMOUNT,5) * VAR17) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < ((0 - 0.4) * VAR17));
 VAR21:=HHV(HIGH,500);
 VAR22:=LLV(LOW,500);
 VAR23:=HHV(HIGH,250);
 VAR24:=LLV(LOW,250);
 VAR25:=HHV(HIGH,125);
 VAR26:=LLV(LOW,125);
 VAR27:=MA(((((((VAR21 * 0.45) + (VAR23 * 0.5)) + VAR22) + VAR24) + VAR26) / 5),35);
 VAR28:=MA((((VAR23 * 0.62) + VAR26) / 2),35);
 VAR29:=MA((((VAR23 * 0.75) + VAR26) / 2),18);
 VAR2A:=MA((((((VAR23 * 0.93) + (VAR27 * 2)) + (VAR28 * 1.8)) + (VAR29 * 1.5)) / 4),18);
 VAR2B:=MA(((((VAR21 * 0.95) + (VAR27 * 3)) + (VAR28 * 2)) / 3),35);
 VAR2C:=VAR27;
 VAR2D:=VAR28;
 VAR2E:=VAR29;
 VAR2F:=VAR2A;
 VAR30:=VAR2B;
 VAR31:=((CLOSE - REF(MA(CLOSE,20),11)) < (0 - 2));
 VAR32:=(INDEXA / 100000000);
 VAR33:=INDEXADV;
 VAR34:=INDEXDEC;
 VAR35:=((VAR18 / (VAR18 + VAR19)) * VAR17);
 VAR36:=((VAR19 / (VAR18 + VAR19)) * VAR17);
 VAR37:=EMA(VAR35,10);
 VAR38:=EMA(VAR36,10);
 VAR39:=EMA(VAR37,10);
 VAR3A:=EMA(VAR38,20);
 VAR3B:=EMA(VAR37,3);
 VAR3C:=EMA(VAR39,6);
 VAR3D:=EMA(VAR3A,2);
 VAR3E:=(VAR3C - VAR3D);
 VAR3F:=(((VAR3C - REF(VAR3C,1)) > 0) AND ((REF(VAR3C,1) - REF(VAR3C,2)) < 0));
 VAR40:=IF((CROSS(VAR3B,VAR3C) AND (VAR3C <= 20)),30,0);
 VAR41:=VAR40;
 VAR42:=(SMA(((AMOUNT / VOL) / 100),13,1) * 1.15);
 VAR43:=(SMA(((AMOUNT / VOL) / 100),13,1) * 0.85);
 VAR44:=(CLOSE - REF(MA(CLOSE,20),11));
 VAR45:=(((((((((((((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43)) OR (((CLOSE < VAR1E) AND VAR31) AND VAR20)) OR ((CLOSE < VAR1E) AND (CLOSE < VAR43))) OR (((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43))) OR (VAR20 AND (CLOSE < VAR2C))) OR ((VAR20 AND VAR31) AND (VAR44 < (0 - 1.5)))) OR (VAR20 AND (CLOSE < VAR1E))) OR (VAR20 AND (VAR44 < (0 - 1.5)))) OR (VAR31 AND (CLOSE < VAR43))) OR ((CLOSE < VAR2C) AND (VAR44 < (0 - 1.5)))) OR ((CLOSE < VAR1E) AND VAR31));
 VAR46:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
 VAR47:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
 VAR48:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
 VAR49:=REF(CLOSE,1);
 VAR4A:=((SMA(MAX((CLOSE - VAR49),0),5,1) / SMA(ABS((CLOSE - VAR49)),5,1)) * 100);
 VAR4B:=(((HIGH + LOW) + CLOSE) / 3);
 VAR4C:=((VAR4B - MA(VAR4B,14)) / (0.015 * AVEDEV(VAR4B,14)));
 VAR4D:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273));
 VAR4E:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));
 VAR4F:=(VAR11 AND VAR12);
 VAR50:=((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 7))) AND (VAR3 <= (0 - 11))) AND (VAR4 <= (0 - 14)));
 VAR51:=(COUNT(VAR50,1) >= 1);
 VAR52:=(VAR4F AND VAR51);
 VAR53:=(((((VAR20 AND (CLOSE < VAR1E)) AND VAR31) AND (CLOSE < VAR2C)) AND VAR45) AND VAR52);
 VAR54:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
 VAR55:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
 VAR56:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
 VAR57:=REF(CLOSE,1);
 VAR58:=((SMA(MAX((CLOSE - VAR57),0),5,1) / SMA(ABS((CLOSE - VAR57)),5,1)) * 100);
 VAR59:=(((HIGH + LOW) + CLOSE) / 3);
 VAR5A:=((VAR59 - MA(VAR59,14)) / (0.015 * AVEDEV(VAR59,14)));
 VAR5B:=((((((VAR54 >= (0 - 15.8)) AND (VAR54 <= (0 - 12.2))) AND (VAR55 <= (0 - 20.8))) AND (VAR56 <= (0 - 27.5))) AND (VAR58 <= 11.7)) AND (VAR5A <= (0 - 145)));
 VAR5C:=9.999999884842E+0.26;
 VAR5D:=((10) * 0);
 VAR5E:=((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100));
 VAR5F:=MA((((LLV(LOW,45) - CLOSE) / (HHV(HIGH,45) - LLV(LOW,45))) * 100),5);
 VAR60:=((CROSS((0 - 5),VAR5F) AND (VAR5E < (0 - 0.4))) AND (((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.19)));
 VAR61:=MA(CLOSE,3);
 VAR62:=(REF(CLOSE,2) * 0.865);
 VAR63:=(REF(CLOSE,13) * 0.772);
 VAR64:=MIN(VAR62,VAR63);
 VAR65:=((100 * VOL));
 VAR66:=MA(CLOSE,13);
 VAR67:=IF(((((CLOSE - VAR64) / CLOSE) < 0.03) AND ((SUM(VAR65,5) / 5) < 1.8)),1,0);
猎鹰出击:IF(((((VAR9 OR VAR16) OR VAR53) OR VAR5B) OR ((((CLOSE - VAR64) / CLOSE) < 0.03) AND ((SUM(VAR65,5) / 5) < 1.8))),120,0),LINETHICK2,COLORRED;
 VAR68:=0;
MACD:(VAR6 * 5),COLORSTICK,LINETHICK2;
 STICKLINE((CROSS(K,D) AND (BB10 > 1)),70,0,2,0),COLORCC99FF;
 DRAWTEXT((CROSS(K,D) AND (BB10 > 1)),64,'--短买'),COLORGREEN;
 DRAWICON((CROSS(K,D) AND (BB10 > 1)),70,0);
底部预警:STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),5,0),COLOR88B7EA;
 VARQ:=MA(CLOSE,152);
 VARW:=MA(CLOSE,194.16);
 VAE:=(VARW + (2 * STD(CLOSE,170)));
 VARR:=(VARQ + (2 * STD(CLOSE,170)));
 VART:=IF((DATE > 1080822),0,1);
 VA61:=EMA(HHV(HIGH,500),21);
 VAR71:=EMA(HHV(HIGH,250),21);
 VAR81:=EMA(HHV(HIGH,90),21);
 VAR91:=EMA(LLV(LOW,500),21);
 VARA1:=EMA(LLV(LOW,250),21);
 VARB1:=EMA(LLV(LOW,90),21);
 VARC1:=EMA((((((((VAR91 * 0.96) + (VARA1 * 0.96)) + (VARB1 * 0.96)) + (VA61 * 0.558)) + (VAR71 * 0.558)) + (VAR81 * 0.558)) / 6),21);
 VARD1:=EMA((((((((VAR91 * 1.25) + (VARA1 * 1.23)) + (VARB1 * 1.2)) + (VA61 * 0.55)) + (VAR71 * 0.55)) + (VAR81 * 0.65)) / 6),21);
 VARE1:=EMA((((((((VAR91 * 1.3) + (VARA1 * 1.3)) + (VARB1 * 1.3)) + (VA61 * 0.68)) + (VAR71 * 0.68)) + (VAR81 * 0.68)) / 6),21);
 VARF1:=EMA((((((VARC1 * 3) + (VARD1 * 2)) + VARE1) / 6) * 1.738),21);
 VAR101:=REF(LOW,1);
 VAR111:=((SMA(ABS((LOW - VAR101)),3,1) / SMA(MAX((LOW - VAR101),0),3,1)) * 100);
 VAR121:=EMA(IF(((CLOSE * 1.35) <= VARF1),(VAR111 * 10),(VAR111 / 10)),3);
 VAR131:=LLV(LOW,30);
 VAR141:=HHV(VAR121,30);
 VAR151:=IF(MA(CLOSE,58),1,0);
 VAR161:=((EMA(IF((LOW <= VAR131),((VAR121 + (VAR141 * 2)) / 2),0),3) / 618) * VAR151);
 VAR171:=(((IF((VAR161 > 50),50,VAR161) / 20) * 15) * VART);
底部吸筹:STICKLINE((VAR171 > 0),0,VAR171,1,1),COLORFF00FF;
 
 STICKLINE(((CROSS(K,D) AND ((AA10 - REF(AA10,1)) > 0)) AND (K <= 49)),80,0,3,0),COLORRED;
 DRAWTEXT(((CROSS(K,D) AND ((AA10 - REF(AA10,1)) > 0)) AND (K <= 49)),80,'--抄底'),COLORRED;
 STICKLINE(CROSS(90,J),88,100,2,0),COLORGREEN;
 DRAWTEXT(CROSS(90,J),108,'。逃'),COLORFFFFFF;
 STICKLINE(CROSS(J,(0 - 5)),0,10,6,0),COLORGREEN;
 DRAWTEXT(CROSS(J,(0 - 5)),(0 - 4),'。低吸'),COLORGREEN;
 SG:=EMA(HHV(HIGH,1),8);
 X1:=EMA(CLOSE,8);
 X30:=((X1 < REF(X1,1)) AND (CLOSE < X1));
 X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
全仓出击:=((((COUNT((X31 = 1),4) = 3) AND (X31 = 0)) AND (((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) > 0.085)) * 89);
 STICKLINE(全仓出击,89,0,3,0),COLORRED;
 DRAWICON((全仓出击 >= 89),全仓出击,1);
 DRAWTEXT((全仓出击 >= 89),89,'--大胆杀入');
开始关注:STICKLINE((VAR6 <= (0 - 8)),5,25,7,0);
 STICKLINE((CROSS(J,0) AND (VAR6 <= (0 - 7))),0,100,8,0),COLOR780000;
 STICKLINE((CROSS(J,0) AND (VAR6 <= (0 - 7))),0,100,6,0),COLOR9D0000;
 STICKLINE((CROSS(J,0) AND (VAR6 <= (0 - 7))),0,100,5,0),COLORFF0000;
 STICKLINE((CROSS(J,0) AND (VAR6 <= (0 - 7))),0,100,2,0),COLOR7AB500;
 DRAWTEXT((CROSS(J,0) AND (VAR6 <= (0 - 7))),100,'--导弹发射'),COLOR0000FF;
均5:=MA(CLOSE,4);
 X7:=EMA(EMA(EMA(HIGH,9),9),9);
海底:=(X7 * 0.92);
海底2:=(X7 * 0.933);
中轨道:=MA(CLOSE,2);
 DRAWTEXT(((CROSS(中轨道,均5) AND (LOW <= 海底)) AND (CLOSE >= 海底2)),85,'-底部'),COLORFFFF00;
 STICKLINE(((CROSS(中轨道,均5) AND (LOW <= 海底)) AND (CLOSE >= 海底2)),0,85,4,0),COLORFFFF00;
通达信很好的MACD+KDJ指标公式

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
通达信很好的MACD+KDJ指标公式下载
精品股票公式