未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股海绝技 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 通达信公式 > 正文
通达信一线穿3线主图源码
  • 相关简介: 通达信指标:一线穿3线主图 LC:=REF(C,1); M5:MA(C,5); M10:MA(C,10); M20:MA(C,20); M30:MA(C,30),COLORFFCC00; VAR1:=EMA(EMA(C,9),9); 控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000; EEM8:=EMA(EMA(C,8),8); 资金:=(EEM8-REF(EEM8,1))/REF(EEM8,1)*1000; 有庄:=资金0; 无庄:=资金=0; 买线:=EMA(C
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境:
  • 编辑发布: 股海网
  • 软件来源: Internet
  • 加入时间: 2019/3/15 8:02:33
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

通达信指标:一线穿3线主图


LC:=REF(C,1);
M5:MA(C,5);
M10:MA(C,10);
M20:MA(C,20);
M30:MA(C,30),COLORFFCC00;
VAR1:=EMA(EMA(C,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
EEM8:=EMA(EMA(C,8),8);
资金:=(EEM8-REF(EEM8,1))/REF(EEM8,1)*1000;
有庄:=资金>0;
无庄:=资金<=0;
买线:=EMA(C,3);
卖线:=EMA(SLOPE(C,22)*20+C,54);
BU1:=CROSS(买线,卖线);
SEL1:=CROSS(卖线,买线);
BU2:=IFF(BU1 AND 有庄,1,IFF(COUNT(BU1 AND 无庄,BARSLAST(SEL1)+1)=1 AND CROSS(资金,0),1,0));
BU:=BU2 AND COUNT(BU2,BARSLAST(SEL1)+1)=1;
SEL:=SEL1 AND COUNT(SEL1,BARSLAST(BU)+1)=1;
止损A:=C/REF(O,BARSLAST(BU))<0.93 AND COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(SEL,BARSLAST(BU)+1)=0;
SELNEW:=IFF(止损A AND COUNT(止损A,BARSLAST(BU)+1)=1,1,IFF(SEL AND COUNT(止损A,BARSLAST(BU)+1)=0,1,0));
重买:=COUNT(止损A,BARSLAST(BU)+1)>=1 AND CROSS(C,0.965*REF(O,BARSLAST(BU)));
不一天:=(重买 AND SELNEW)=0;
BUNEW2:=(BU OR 重买) AND 不一天;
止损B:=(C/REF(O,BARSLAST(重买))<-0.06 AND COUNT(重买,BARSLAST(重买)+1)=1 AND COUNT(SEL,BARSLAST(重买)+1)=0);
重卖:=(SEL AND COUNT(重买,BARSLAST(BUNEW2)+1)=1) OR (止损B AND SUM(止损B,0)=1);
不一天2:=((重卖 AND BUNEW2)=0);
SELNEW2:=((SELNEW AND COUNT(SELNEW,BARSLAST(BUNEW2)+1)=1) OR 重卖) AND 不一天2;
BUNEW3:=BUNEW2 AND COUNT(BUNEW2,BARSLAST(SELNEW2)+1)=1;
SELNEW3:=SELNEW2 AND COUNT(SELNEW2,BARSLAST(BUNEW3)+1)=1;
D:=BARSLAST(BUNEW3)+1>=1 AND COUNT(SELNEW3,BARSLAST(BUNEW3)+1)=0;
K:=BARSLAST(SELNEW3)+1>=1 AND COUNT(BUNEW3,BARSLAST(SELNEW3)+1)=0;
修正定位:=IFF(COUNT(SELNEW3,BARSCOUNT(C))=0 AND COUNT(BUNEW3,BARSCOUNT(C))=0,1,0);
修正累计:=SUM(修正定位,1000)+1;
精准修正累计:=IFF(修正累计=REF(修正累计,1) AND REF(修正累计,2)<修正累计,修正累计,0);
上市修正B:=修正定位 AND CROSS(控盘,0);
上市修正S:=修正定位 AND CROSS(0,控盘) AND COUNT(上市修正B,BARSLAST(C>0))>=1;
上市D:=COUNT(上市修正B,BARSLAST(上市修正B)+1)=1 AND COUNT(上市修正S,BARSLAST(上市修正B)+1)=0 AND COUNT (SELNEW3,BARSCOUNT(C))=0;
上市K:=COUNT(上市修正S,BARSLAST(上市修正S)+1)=1 AND COUNT(上市修正B,BARSLAST(上市修正S)+1)=0 AND COUNT
(BUNEW3,BARSCOUNT(C))=0;
SSXZBZS:=COUNT(上市修正B,BARSCOUNT(C));
SSXZSZS:=COUNT(上市修正S,BARSCOUNT(C));
QB:=IFF(修正定位,上市修正B,BUNEW3);
QS:=IFF(修正定位,上市修正S AND (SSXZBZS==SSXZSZS AND SSXZBZS>=0 AND COUNT(SELNEW3,BARSCOUNT(C))=1 AND COUNT
(BUNEW3,BARSCOUNT(C))=0)=0, SELNEW3 AND (SSXZBZS=SSXZSZS AND SSXZBZS>=0 AND COUNT(SELNEW3,BARSCOUNT(C))=1 AND COUNT
(BUNEW3,BARSCOUNT(C))=0)=0);
K补:=(COUNT(上市修正B,BARSLAST(C>0))=0 AND COUNT(QB,BARSLAST(C>0))==0)==0;
STICKLINE(D OR 上市D,H,L,0,0),COLOR0000EE;
STICKLINE(D OR 上市D,C,O,2,0),COLOR0000EE;
STICKLINE((K AND K补) OR 上市K,H,L,0,0),COLORFFBB00;
STICKLINE((K AND K补) OR 上市K,C,O,2,0),COLORFFBB00;
DRAWICON(QB,L*0.975,23);
DRAWICON(QS,H*1.02,27);
一线穿3线:IF(C>MAX(M5,MAX(M10,MIN(M20,M30))) AND LC<=(MIN(REF(M5,1),MIN(REF(M10,1),
MAX(REF(M20,1),REF(M30,1))))),L*0.985,DRAWNULL),COLOR00FFFF,LINETHICK6,CROSSDOT;
一线破3线:IF(C<MIN(M5,MIN(M10,MAX(M20,M30))) AND LC>=(MAX(REF(M5,1),MAX(REF(M10,1),
MIN(REF(M20,1),REF(M30,1))))),H*1.01,DRAWNULL),COLOR00FF00,LINETHICK6,CROSSDOT;
STICKLINE(一线穿3线=L*0.985,C,O,2,0),COLORFF00FF;
STICKLINE(一线破3线=H*1.01,C,O,2,0),COLOR00FF00;
 


通达信一线穿3线主图源码

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
通达信一线穿3线主图源码下载
精品股票公式