未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股海绝技 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 公式教程答疑 > 正文
出现“突破白线”选股
  • 相关简介: 编写要求: www.guhai.com.cn 股海网解答: 网友求助: A0:=(L+H+C*2)/4; A1:EMA(A0,14)COLORBLUE,LINETHICK2; A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2; A1X:=(A1-REF(A1,1))/REF(A1,1)*100,LINETHICK0; A2X:=(A2-REF(A2,1))/REF(A2,1)*100,LINETHICK0; 出击:PARTLINE(A1X=0 AND BARSLAST(
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境:
  • 编辑发布: 股海网
  • 软件来源: Internet
  • 加入时间: 2019/5/6 7:43:33
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

编写要求:

 

www.guhai.com.cn股海网解答:

 网友求助:

A0:=(L+H+C*2)/4;
A1:EMA(A0,14)COLORBLUE,LINETHICK2;
A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,LINETHICK0;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,LINETHICK0;
出击:PARTLINE(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))),COLORMAGENTA,LINETHICK2;
逃遁:PARTLINE(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X)))),COLORGREEN,LINETHICK2;
盈10%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.1,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.1),COLORWHITE,POINTDOT;
盈20%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.2,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.2),COLORWHITE,POINTDOT;
盈30%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.3),COLORWHITE,POINTDOT;
盈40%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.4,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.4),COLORWHITE,POINTDOT;
盈50%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.5,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.5),COLORWHITE,POINTDOT;
铁:PARTLINE(A1X>=0,A1)COLORffffff,LINETHICK2;
律:PARTLINE(A1X<0 AND A2X<0,A1)COLORGREEN,LINETHICK2;
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,10,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,4,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;
STICKLINE(CROSS(0,A1X),C,O,8,0),COLOR00CC00;
STICKLINE(CROSS(0,A1X),C,O,4,0),COLOR66FF00;
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
周MA30:MA(MA30,5),colorFF00ff,linethick2;
PARTLINE(周MA30<REF(周MA30,1),周MA30),LINETHICK2,colorgray;
周MA60:MA(MA60,5),colorFF,linethick2;
PARTLINE(周MA60<REF(周MA60,1),周MA60),LINETHICK2,colorgray;
【量H】:=IF((AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100);
STICKLINE(【量H】=100,L,H,0.8,0),COLORYELLOW;
STICKLINE(【量H】=100 AND C>=O,C,O,5,1),COLORYELLOW;
STICKLINE(【量H】=100 AND C<O,C,O,5,0),COLORYELLOW;
TTJ:=BARSLAST((VOL=HHV(VOL,21)));
K0:=TTJ=0;
K1:=SUMBARS(K0,1);
K2:=SUMBARS(K0,2);
K3:=SUMBARS(K0,3);
K4:=SUMBARS(K0,4);
K5:=SUMBARS(K0,5);
K6:=SUMBARS(K0,6);
K7:=SUMBARS(K0,7);
K8:=SUMBARS(K0,8);
K9:=SUMBARS(K0,9);
K10:=SUMBARS(K0,10);
C1:=REF(C,K1-1);
AA:STICKLINE(K1<=30,REF(C,K1-1)*1,REF(C,K1-1),10,0),COLORYELLOW;
MA6:=MA(CLOSE,6);
MA18:=MA(CLOSE,18);
MA3:=(3)*(MA18) - (2)*(MA6),LINETHICK1,COLORD39D91;
MA4:=(3)*(MA6) - (2)*(MA18),LINETHICK2,COLOR87B08B;
M1:=SUM((EMA((CLOSE + LOW)/(2),2))/(2.98),3),POINTDOT,COLORFFFFFF;
M2:=EMA(M1,21),COLORFF00FF;
M30:=MA(CLOSE,30),LINETHICK1,COLORFF0000;
VAR1:=(2)*(MA((LLV((CLOSE + LOW)/(2),8))*(1.1),13)) - EMA((CLOSE + LOW)/(2),3) - ((CLOSE + LOW)/(2))*(0.1);
VAR2:=IF(((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5) > 0),(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2))/(10),(((-1))*(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2)))/(10));
VAR3:=IF((VAR2 > 0),VAR2 - 0,(-1));
DRAWTEXT(CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8)),(M2)*(1.01),'突破白线'),LINETHICK2,COLORffffff;
STICKLINE(CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8)),(LOW)*(0.99),(LOW)*(0.95),4,0),COLORffffff; 买:CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8)),LINETHICK0;
天:COUNT(CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8)),20),COLORRED,LINETHICK0;
 

解答如下:
A0:=(L+H+C*2)/4;
A1:=EMA(A0,14);
A2:=EMA(A0,25);
A1X:=(A1-REF(A1,1))/REF(A1,1)*100;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100;
出击:=PARTLINE(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))));
逃遁:=PARTLINE(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))));
盈10%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.1,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.1);
盈20%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.2,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.2);
盈30%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.3);
盈40%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.4,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.4);
盈50%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.5,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.5);
铁:=PARTLINE(A1X>=0,A1);
律:=PARTLINE(A1X<0 AND A2X<0,A1);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
周MA30:=MA(MA30,5),colorFF00ff,linethick2;
周MA60:=MA(MA60,5),colorFF,linethick2;
【量H】:=IF((AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100);
K0:=TTJ=0;
K1:=SUMBARS(K0,1);
K2:=SUMBARS(K0,2);
K3:=SUMBARS(K0,3);
K4:=SUMBARS(K0,4);
K5:=SUMBARS(K0,5);
K6:=SUMBARS(K0,6);
K7:=SUMBARS(K0,7);
K8:=SUMBARS(K0,8);
K9:=SUMBARS(K0,9);
K10:=SUMBARS(K0,10);
C1:=REF(C,K1-1);
MA6:=MA(CLOSE,6);
MA18:=MA(CLOSE,18);
MA3:=(3)*(MA18) - (2)*(MA6);
MA4:=(3)*(MA6) - (2)*(MA18);
M1:=SUM((EMA((CLOSE + LOW)/(2),2))/(2.98),3);
M2:=EMA(M1,21),COLORFF00FF;
M30:=MA(CLOSE,30),LINETHICK1,COLORFF0000;
VAR1:=(2)*(MA((LLV((CLOSE + LOW)/(2),8))*(1.1),13)) - EMA((CLOSE + LOW)/(2),3) - ((CLOSE + LOW)/(2))*(0.1);
VAR2:=IF(((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5) > 0),(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2))/(10),(((-1))*(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2)))/(10));
VAR3:=IF((VAR2 > 0),VAR2 - 0,(-1));
XG:CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8));
 

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
出现“突破白线”选股下载