未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股海绝技 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 公式教程答疑 > 正文
把六指金叉里涨不停等于1改选股
  • 相关简介: 编写要求: 股旁 www.guhai.com.cn 股海 网友求助: {DRAWGBK(1,COLORRGB(0,0,30),COLORRGB(0,0,100),1);} N1:=3;N2:=9;N3:=12;N4:=26; DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4); DEA:=EMA(DIFF,N2); DRAWICON(DIFFDEA,1,4); DRAWICON(DIFFDEA,1,5); DRAWTEXTEX(1,1,980,950,'MACD'),colorF
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境:
  • 编辑发布: 股海网
  • 软件来源: Internet
  • 加入时间: 2019/7/8 7:40:00
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

编写要求:

 

股旁www.guhai.com.cn股海 网友求助:

{DRAWGBK(1,COLORRGB(0,0,30),COLORRGB(0,0,100),1);}
N1:=3;N2:=9;N3:=12;N4:=26;
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
DRAWICON(DIFF>DEA,1,4);
DRAWICON(DIFF<DEA,1,5);
DRAWTEXTEX(1,1,980,950,'MACD'),colorFFFFFF;
A1:=DIFF>DEA;
RSV:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV,N1,1);
D:=SMA(K,N1,1);
DRAWICON(K>D,2,4);
DRAWICON(K<D,2,5);
DRAWTEXTEX(1,1,980,770,'KDJ'),colorFFFFFF;
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
DRAWICON(RSI1>RSI2,3,4);
DRAWICON(RSI1<RSI2,3,5);
DRAWTEXTEX(1,1,980,560,'RSI'),colorFFFFFF;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
DRAWICON(LWR1>LWR2,4,4);
DRAWICON(LWR1<LWR2,4,5);
DRAWTEXTEX(1,1,980,370,'LW&R'),colorFFFFFF;
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
DRAWICON(CLOSE>BBI,5,4);
DRAWICON(CLOSE<BBI,5,5);
DRAWTEXTEX(1,1,980,170,'BBI'),colorFFFFFF;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
DRAWICON(MMS>MMM,6,4);
DRAWICON(MMS<MMM,6,5);
DRAWTEXTEX(1,1,980,-15,'ZLMM'),colorFFFFFF;
A6:=MMS>MMM;
VERTLINE(A1 AND A2 AND A3 AND A4 AND A5 AND A6),colorFFFF;
涨不停买入:A1 AND A2 AND A3 AND A4 AND A5 AND A6=1 AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,colorFFFF,LINETHICK2;
DRAWICON(DIFF>DEA,1,4);
DRAWICON(DIFF<DEA,1,5);
DRAWICON(K>D,2,4);
DRAWICON(K<D,2,5);
DRAWICON(RSI1>RSI2,3,4);
DRAWICON(RSI1<RSI2,3,5);
DRAWICON(LWR1>LWR2,4,4);
DRAWICON(LWR1<LWR2,4,5);
DRAWICON(CLOSE>BBI,5,4);
DRAWICON(CLOSE<BBI,5,5);
DRAWICON(MMS>MMM,6,4);
DRAWICON(MMS<MMM,6,5);
 
 
解答如下:
N1:=3;N2:=9;N3:=12;N4:=26;
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
A1:=DIFF>DEA;
RSV:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV,N1,1);
D:=SMA(K,N1,1);
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
A6:=MMS>MMM;
涨不停买入:A1 AND A2 AND A3 AND A4 AND A5 AND A6=1 AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0;
 

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
把六指金叉里涨不停等于1改选股下载