未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股海绝技 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 通达信公式 > 正文
20个最牛抄底公式及2个组合公式源码
  • 相关简介: 20个最牛抄底公式及2个组合公式源码 {金牛起步} XA_1:=VOLMA(VOL,5) AND MA(VOL,5)MA(VOL,55)*0.8; XA_2:=CLOSE/REF(CLOSE,1)1.028; XA_3:=MA(CLOSE,10)CLOSE*1.05; XA_4:=MA(CLOSE,10)CLOSE*1.1; XA_5:=MA(CLOSE,60)CLOSE*1.28; XA_6:=MACD.MACD(12,26,9)(-0.6); XA_7:=XA_1 AND XA_2 AND
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境: 通达信
  • 编辑发布: 股海网
  • 软件来源: Internet
  • 加入时间: 2019/1/25 22:06:12
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

20个最牛抄底公式及2个组合公式源码

{金牛起步}
XA_1:=VOL<MA(VOL,5) AND MA(VOL,5)<MA(VOL,55)*0.8;
XA_2:=CLOSE/REF(CLOSE,1)>1.028;
XA_3:=MA(CLOSE,10)>CLOSE*1.05;
XA_4:=MA(CLOSE,10)<CLOSE*1.1;
XA_5:=MA(CLOSE,60)>CLOSE*1.28;
XA_6:=MACD.macd(12,26,9)>(-0.6);
XA_7:=XA_1 AND XA_2 AND XA_3 AND XA_4 AND XA_5 AND XA_6;
STICKLINE(XA_7,0,1,5,0),COLOR008877;
STICKLINE(XA_7,0,1,3,0),COLOR00AA99;
STICKLINE(XA_7,0,1,1,0),COLOR00CCBB;
STICKLINE(XA_7,0,1,0.2,0),COLORYELLOW;
{说明:
1,上涨没有放大量,当日成交量还低于5日平均成交量,且成交量5均线小于成交量55的8折,(var1,,是不是想找阶段地量?)
2,当天上涨大于2.8%以上,可能表示有主力行为;(var2)
3,股价还低于10均线,但距离不远,有一个中到大阳线就可以站上;(var3,var4)
4,超跌有反弹,股价远低于60均线;(VAR5)
5,MACD值大于 -0.6;(var6)
其中MACD值这个条件值得商榷,可能是想表示离0轴不远吧。实际上,macd值的单位是元,百元股和十元股的MACD值变化范围有很大区别,直接用有点不合适。}

{海底活鱼}
BIAS0:=(C-MA(C,2))/MA(C,2)*100;
HXL:=V/CAPITAL*100;
D1:=INDEXC;
D2:=MA(D1,13);
DR2:=D2>1.050*D1;
E1:=(C-HHV(C,12))/HHV(C,12)*10;
E2:=(C-REF(C,26))/REF(C,26)*10;
E3:=MA(C,3);
SJ1:=DR2;
SJ2:=E2<-2.30;
SJ3:=BIAS0<-2.7;
SJ5:=SJ1 AND SJ2 AND SJ3;
SJ6:=CROSS(0.5,SJ5);
JS1:=CROSS(SJ6,0.5);
JS2:=BARSLAST(JS1=1);
JS3:=JS2<=5 AND C<REF(C,JS2);
PMDY:=SJ6 OR JS3;
VAR1:=CLOSE/MA(CLOSE,20)*100<80;
VAR2:=CLOSE/MA(CLOSE,40)*100<78;
VAR3:=CLOSE/MA(CLOSE,60)*100<72;
VAR4:=HIGH>LOW*1.051;
VAR5:=VAR4 AND COUNT(VAR4,5)>1;
XG:PMDY AND VAR5 AND (VAR1 OR VAR2 OR VAR3);

{钻石底}
VBR:=C<REF(C,4);
NT0:=BARSLASTCOUNT(VBR);TJ21:=NT0=6 ;底6:=COUNT(NT0=6,5)=1;
VBR1:=DMA(CLOSE,VOL/SUM(VOL,34));VBR2:=DMA(CLOSE,VOL/SUM(VOL,13));
VBR3:=(CLOSE-VBR1)/VBR1*100;VBR4:=(CLOSE-VBR2)/VBR2*100;Y1:=VBR4<=-17 AND VBR3<=-25;
去除ST:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),0,1);
去除停牌:=DYNAINFO(4)>0;
去除:=去除ST AND 去除停牌;
Q1:=底6 AND Y1 AND 去除;
超卖区:=MA((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,2);
Q2:=超卖区<-20 ;
钻石底XG:Q1 AND Q2 AND O!=C AND C>REF(C,1)*0.91 AND C<REF(C,1)AND INDEXC<REF(INDEXC,1) AND REF(C>REF(C,1),1);

{核心低点}
X_01:=O/HHV(C,30)<0.78;
X_02:=C/MA(C,50)<0.78;
X_03:=O=LLV(O,30);
X_04:=C/SMA(C,13,1)-1;
X_05:=REF(X_04,1)<-0.13;
X_06:=REF(X_04,1)/X_04>1.25;
X_07:=REF(C,1)<=COST(5);
X_08:=COUNT(H>L*1.05,5)>2;
核心低点:X_01 AND X_02 AND X_03 AND X_05 AND X_06 AND X_07 AND X_08;

{率土之滨}
X01:=MA(C,10)/C>1.055;
X02:=MA(C,10)/C<1.1;
X03:=MA(C,60)/C>1.28;
X04:=C/REF(C,1)>1.028;
X05:=H>L*1.05 AND COUNT(H>L*1.05,5)>3;
X06:=O/HHV(C,30)<0.78;
X07:=V<MA(V,5) AND MA(V,5)<MA(V,55);
X08:=O=LLV(O,30);
率土之滨XG:X01 AND X02 AND X03 AND X04 AND X05 AND X06 AND X07 AND X08;

{神剑出鞘}
C2_VAR100:=IF(DATE<=1280831,1,0);
C2_CSS:=((C-LLV(L,8))/(HHV(H,8)-LLV(L,8))*100)*C2_VAR100;
C2_YJDD:=(EMA(C2_CSS,3)-50)*2*C2_VAR100;
C2_强弱:=(C2_YJDD+100)/2*C2_VAR100;
C2_T1:=(INDEXC-MA(INDEXC,58))/MA(INDEXC,58)<-0.152;
C2_T2:=(C-EMA(C,58))/EMA(C,58)<-0.19;
C2_买1:=C2_T2 AND C2_T1;
C2_T3:=IF(DATE<=1280831,1,0);
C2_T4:=(C-MA(C,2))/MA(C,2)*100*C2_T3;
C2_T5:=INDEXC*C2_T3;
C2_T6:=MA(C2_T5,13)*C2_T3;
C2_T7:=C2_T6>1.050*C2_T5*C2_T3;
C2_T8:=(C-REF(C,26))/REF(C,26)*10*C2_T3;
C2_T9:=C2_T7*C2_T3;
C2_T10:=C2_T8<-2.30 AND C2_T3;
C2_T11:=C2_T4<-2.7 AND C2_T3;
C2_T12:=C2_T9 AND C2_T10 AND C2_T11 AND C2_T3;
C2_T13:=CROSS(0.5,C2_T12)*C2_T3;
C2_T14:=CROSS(C2_T13,0.5)*C2_T3;
C2_T15:=BARSLAST(C2_T14=1)*C2_T3;
C2_T16:=C2_T15<=5 AND C<REF(C,C2_T15) AND C2_T3;
C2_买2:=C2_T13 OR C2_T16;
C2_T17:= (C-MA(C,2))/MA(C,2)*100;
C2_T18:=INDEXC;
C2_T19:=MA(C2_T18,56);
C2_T20:=C2_T18/C2_T19<0.94;
C2_T21:=(C-REF(C,26))/REF(C,26)*10;
C2_T22:=C2_T20;
C2_T23:=C2_T21<-2.55;
C2_T24:=C2_T17<-2.7;
C2_T25:=C2_T22 AND C2_T23 AND C2_T24;
C2_T26:=CROSS(0.5,C2_T25);
C2_T27:=CROSS(C2_T26,0.5);
C2_T28:=BARSLAST(C2_T27=1);
C2_T29:=C2_T28<=5 AND C<1.02*REF(C,C2_T28);
C2_底4:=C2_T26 OR C2_T29;
C2_T30:= (C-MA(C,2))/MA(C,2)*100;
C2_T31:=INDEXC;
C2_T32:=MA(C2_T31,13);
C2_T33:=C2_T32>1.050*C2_T31;
C2_T34:=(C-REF(C,26))/REF(C,26)*10;
C2_T35:=C2_T33;
C2_T36:=C2_T34<-2.69;
C2_T37:=C2_T30<-3.09;
C2_T38:=C2_T35 AND C2_T36 AND C2_T37;
C2_T39:=CROSS(0.5,C2_T38);
C2_T40:=CROSS(C2_T39,0.5);
C2_T41:=BARSLAST(C2_T40=1);
C2_T42:=C2_T41<=5 AND C<REF(C,C2_T41);
C2_买3:=COUNT(C2_T39 OR C2_T42,4)=4;
C2_T43:=EMA(((C*1.1-LLV(L,630))/(HHV(H,630)-LLV(L,630))-(C*0.9-LLV(L,630))/(HHV(H,630)-LLV(L,630)))*80,5);
C2_T44:=INDEXC;
C2_T45:=MA(C2_T44,5);
C2_T46:=MA(C2_T44,20);
C2_T47:=MA(C2_T44,30);
C2_T48:=C2_T45>C2_T44*1.03 AND C2_T46>C2_T44*1.13;
C2_T49:=C2_T48;
C2_目标:=COUNT(C2_T43<6 AND C2_T49,3)>=3;
C2_新目标:=C2_买3 OR C2_目标;
神剑出鞘:IF(((COUNT(C2_买1 AND C2_底4,6)=6 OR COUNT(C2_买1 AND C2_买2,4)=4 OR COUNT(C2_买2 AND C2_底4,5)=5) OR C2_新目标) AND DATE<=1280831,90,0);

{神算大}
BIAS0:=(C-MA(C,2))/MA(C,2)*100;
D1:=INDEXC;
D2:=MA(D1,13);
DR2:=D2>1.050*D1;
E2:=(C-REF(C,26))/REF(C,26)*10;
SJ1:=DR2;
SJ2:=E2<-2.30;
SJ3:=BIAS0<-2.7;{-1.3}
SJ5:=SJ1 AND SJ2 AND SJ3;
神算大:CROSS(0.5,SJ5);

{春笋}
DIF:=(CLOSE-SMA(CLOSE,7,1))/SMA(CLOSE,7,1)*(-100);
DEA:=REF(DIF,1)>13 AND REF(DIF,1)/DIF>1.3 AND CLOSE/REF(CLOSE,1)>1.03;
春笋:IF(DEA AND REF(CLOSE,1)<=COST(5),1,0) AND C<MA(C,60)
{AA:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
BB:=REF(AA,1)>13 AND REF(AA,1)/AA>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
春笋:=BB AND REF(CLOSE,1)<=COST(5),COLORCYAN;}

{短线黑马}
K:=100;
VAR1C:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR2C:=DMA(CLOSE,VOL/MA(VOL,33)/33);
VAR3C:=(CLOSE-VAR1C)/VAR1C*100<-11/K*100;
VAR4C:=(VAR1C-VAR2C)/VAR2C*100<-22.3/K*100;
VAR5C:=VAR3C AND VAR4C AND (OPEN>CLOSE OR OPEN<CLOSE) AND
(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 AND
(REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) AND
(REF(OPEN,2)>REF(CLOSE,2) OR REF
(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF
(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)
<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF
(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7));
VAR6C:=DMA(CLOSE,VOL/MA(VOL,3)/3);
VAR7C:=DMA(CLOSE,VOL/MA(VOL,33)/33);
VAR8C:=(CLOSE-VAR6C)/VAR6C*100<-5;
VAR9C:=(VAR6C-VAR7C)/VAR7C*100<-18;
VARAC:=(INDEXC-LLV(INDEXL,250))/(HHV(INDEXH,250)-LLV(INDEXL,250))*100;
VARBC:=SMA(VARAC,30,1);
VARCC:=SMA(VARBC,50,1);
VARDC:=VAR8C AND VAR9C AND (OPEN>CLOSE OR OPEN<CLOSE) AND
(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05 AND
(REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));
VAREC:=VARDC AND COUNT(VARDC,2)=1 ;
短线黑马:VAR5C OR VAREC,COLORRED;

{耍无赖}
BIAS0:= (C-MA(C,3))/MA(C,3)*100;
HXL:=V/CAPITAL*100;
D1:=INDEXC;
D2:=MA(D1,13);
DR2:=D2>1.050*D1;
E1:=(C-HHV(C,13))/HHV(C,13)*10;
E2:=(C-REF(C,21))/REF(C,21)*10;
E3:=MA(C,3);
SJ1:=DR2;
SJ2:=E2<-2.30;
SJ3:=BIAS0<-2.7;
SJ5:=SJ1 AND SJ2 AND SJ3;
SJ6:=CROSS(0.5,SJ5);
JS1:=CROSS(SJ6,0.5);JS2:=BARSLAST(JS1=1);
JS3:=JS2<=5 AND C<REF(C,JS2);
TJ:=SJ6 OR JS3 ;
耍无赖:TJ=0 AND REF(TJ=1,1);

{大魔鬼}
风险值:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3)<=10;
机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1);
HJ_1:=CLOSE/MA(CLOSE,40);
HJ_2:=CLOSE/MA(CLOSE,60)*100<71;
大魔鬼:CROSS(HJ_1,HJ_2) AND 风险值 AND 机会来临 ;

{决策玄机3}
VAR1:=EMA(CLOSE,24);
LD:=EMA(VAR1*0.8,5);
TJ2:COUNT(O=C AND (REF(C,1)-C)/REF(C,1)>0.098,13);
TJ1:(REF(LD,1)>REF(C,1) AND C>LD AND C>REF(C,1)*1.02 AND TJ2<1) ;
XG:FILTER(TJ1,3);

{波段潜伏}
C1:=((MA(C,30)-L)/MA(C,60))*200;
M1:=REF(CLOSE,1);
M2:=SMA(MAX(CLOSE-M1,0),7,1)/SMA(ABS(CLOSE-M1),7,1)*100;
G1:=FILTER(REF(M2,1)<20 AND M2>REF(M2,1),5);
TU:=C/MA(C,40)<0.74;
TDJ:=(H-L)/REF(C,1)>0.05;
YUL:=COUNT(TDJ,5)>1;
启动:=TU AND TDJ AND YUL;
波段潜伏:FILTER((G1 AND C1>20 OR C>REF(C,1)) AND REF(启动,1),10);

{智取妖底}
A1:=((MA(C,60)-L)/MA(C,20))*200;
B1:=((MA(C,60)-L)/MA(C,60))*200;
C1:=((MA(C,30)-L)/MA(C,60))*200;
M1:=REF(CLOSE,1);
M2:=SMA(MAX(CLOSE-M1,0),7,1)/SMA(ABS(CLOSE-M1),7,1)*100;
G1:=FILTER(REF(M2,1)<20 AND M2>REF(M2,1),5);
TU:=C/MA(C,40)<0.74;
PER1:=5;
MMA:=EMA(C,PER1);
SMMA:=EMA(MMA,PER1);
IMPETMMA:=MMA - REF(MMA,1);
IMPETSMMA:=SMMA - REF(SMMA,1);
DIVMA:= ABS(MMA - SMMA);
TDJ:=(H-L)/REF(C,1)>0.05;
AVERIMPET:= (IMPETMMA+IMPETSMMA)/2;
TDF:= POW(DIVMA,1)*POW(AVERIMPET,3);
NTDF:=TDF/HHV(ABS(TDF),PER1*3);
YUL:=COUNT(TDJ,5)>1;
启动:=TU AND TDJ AND YUL;
确定:=CROSS(NTDF,-0.9);
波段:=FILTER((G1 AND C1>20 OR C>REF(C,1)) AND REF(启动,1),10);
选股:=FILTER(REF(启动,1) AND (确定 OR C>REF(C,1)) AND "MACD.MACD">-1.5,10);
妖底:COUNT(选股,13)>=1 AND 波段;

{底部区域}
BIAS0:=(C-MA(C,3))/MA(C,3)*100;           
HXL:=V/CAPITAL*100;                       
D1:=INDEXC;                               
D2:=MA(D1,5);                             
DR2:=D2>1.05*D1;                          
E1:=(C-HHV(C,13))/HHV(C,13)*10;           
E2:=(C-REF(C,21))/REF(C,21)*10;           
E3:=MA(C,5);                              
SJ1:=DR2;                                 
SJ2:=E2<-2.30;                            
SJ3:=BIAS0<-2.7;                          
SJ5:=SJ1 AND SJ2 AND SJ3;                 
SJ6:=CROSS(0.55,SJ5);                     
JS1:=CROSS(SJ6,0.5);JS2:=BARSLAST(JS1=1); 
JS3:=JS2<=5 AND C<REF(C,JS2);             
JS4:=SJ6 OR JS3;                          
XG:REF(JS4,1);

{高精抄底优化}
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
D2:=VAR6<=-10;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,150);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
VAR7:=MACD<0 AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
VAR8:=MACD<0 AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3);
VAR9:=MACD<0 AND REF(MACD,1)<REF(MACD,2);
VAR10:=VAR7 OR VAR8 OR VAR9;
D3:=VAR10;
VAR11:=CLOSE/MA(CLOSE,20)*100<80;
VAR12:=CLOSE/MA(CLOSE,40)*100<78;
VAR13:=CLOSE/MA(CLOSE,60)*100<72;
VAR14:=HIGH>LOW*1.051;
VAR15:=VAR14 AND COUNT(VAR14,5)>1;
VAR16:=(VAR11 AND VAR12) OR (VAR12 AND VAR13) OR (VAR11 AND VAR13);
D4:=VAR15 AND VAR16;
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
AA:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-30) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-30,趋势线),1) AND CROSS(趋势线,-30)) OR 趋势线=-30;
BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
D5:=BB;
XG:D2 AND D3 AND COUNT(D4,3)>=1 AND COUNT(D5,5)>=1;

{macd选股}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA15:=MA(C,15);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA40:=MA(C,40);
MA60:=MA(C,60);
上影线:=(H-MAX(C,O))/(MAX(C,O)-MIN(C,O));
下影线:=(MAX(C,O)-L)/(MAX(C,O)-MIN(C,O));
涨幅:=(C-REF(C,1))/REF(C,1)*100;
振幅:=(H-L)/REF(C,1)*100;
水上金叉:=REF(MACD,3)=LLV(MACD,10) AND REF(MACD<0,3) AND EVERY(MACD>REF(MACD,1),2) AND CROSS(DIF,DEA) AND BETWEEN(HHV(MACD,28)/ABS(LLV(MACD,7)),0.5,1.8) AND
EVERY(DEA>=0,50)  AND NOT(REF((O<MA20 AND C>MA5),2)) AND NOT(O=L)  AND NOT(REF(O=L,2)) AND NOT(O>MA5 AND L<=MA5) AND NOT(REF(H=MA5,3)) AND REF(下影线<5.24,3)
AND NOT(REF(C=L,3)) AND V>REF(V,1)*1.51  AND NOT(C<O) AND NOT(REF(CROSS(MA15,MA10),2))  AND NOT(REF(L<MA5 AND O>MA10 AND O>C,1)) AND NOT(REF(CROSS(MA10,MA5),2));
水下金叉:=REF(MACD,3)=LLV(MACD,11) AND REF(MACD<0,3) AND EVERY(MACD>REF(MACD,1),2) AND CROSS(DIF,DEA)  AND EVERY(DEA<0,14) AND BETWEEN(V,MA(V,10)*0.662,MA(V,10)*0.75)
AND BETWEEN(HHV(MACD,28)/ABS(LLV(MACD,7)),0.8,1.9) AND NOT(CROSS(MA15,MA20)) AND NOT(C=O) AND NOT(REF(CROSS(MA20,MA10),3)) AND NOT(CROSS(MA20,MA10)) AND
NOT(H>MA10 AND CROSS(C,MA10)) AND NOT(H>MA20 AND L<MA5) AND NOT(REF(H>MA20 AND L<MA5,1)) AND NOT(REF(CROSS(MA20,MA10),2)) AND 下影线<15.99 AND
NOT(REF(CROSS(MA15,MA10),1)) AND NOT(O=L)  AND REF(下影线<8.24,2) AND NOT(REF(L<MA5 AND CROSS(C,MA10),1)) AND REF(下影线<5.99,1);
金叉:=水上金叉 OR 水下金叉;
底0:=BETWEEN(LLV(MACD,30),-0.0002,-0.6) AND REF(CROSS(DIF,DEA) AND BETWEEN(V,MA(V,10)*0.35,MA(V,10)*0.75) ,3)  AND CROSS(MA5,MA10) AND BETWEEN(V,REF(V,1)*0.6,REF(V,1)*1.2)
AND NOT(O<MA30 AND C>MA30 AND C>MA20)  AND NOT(L<MA5 AND L<MA30 AND C>MA5) AND NOT(CROSS(MA15,MA30)) AND NOT(CROSS(MA20,MA30)) AND C>O AND 下影线<3.27
AND 上影线<7.74 AND NOT(H>MA20 AND O<MA15 AND MA20>MA15) AND NOT(CROSS(MA5,MA30) AND CROSS(MA5,MA20) AND CROSS(MA5,MA15)) AND NOT(C>MA40 AND L<MA30 AND MA40>MA30)
AND NOT(REF(CROSS(MA10,MA5) AND C>MA60 AND L<MA60,4)) AND NOT(CROSS(MA5,MA30)) AND NOT(CROSS(MA20,MA40)) AND NOT(REF(V>REF(V,1)*2.22,1)) AND NOT(REF(C=O,3))
AND NOT(REF(CROSS(MA5,MA15),1)) ;
底:=底0  AND NOT(REF(CROSS(MA20,MA10),3)) AND NOT(REF(CROSS(MA10,MA5),3))  AND NOT(REF(O>MA10 AND L<MA5 AND MA10>MA5 AND C<O,2))
AND NOT(REF(H>MA20 AND O<MA15,1)) AND REF(下影线<22.99,1) AND NOT(REF(CROSS(C,MA10) AND CROSS(C,MA15),1)) AND REF(上影线<35.99,2);
MACD选股:金叉 OR 底;

{大红马}
VAR10:=EMA(WINNER(C)*70,3);
VAR20:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,3);
VAR30:=C/MA(C,40)*100<76;
VAR40:=C/MA(C,60)*100<74;
VAR50:=H>L*1.051;
VAR60:=VAR50 AND COUNT(VAR50,5)>1;
VAR70:=(WINNER(C*125/100)-WINNER(C))*100<7.5;
VAR80:=1;
TZB:=-0.2*(VAR60 AND (VAR30 OR VAR40) AND VAR20<20 AND VAR10<20 AND VAR70 AND VAR80);
红马:TZB<0 AND REF(TZB,1)=0 ;

{飞扬抄底}
MA1:=MA((HIGH+LOW)/2,5);
MA2:=MA((HIGH+LOW)/2,35);
OMM:=MA1-MA2;
BDK:=LLV(OMM,15)=LLV(OMM,30) AND HHV(OMM,10)=HHV(OMM,15) AND OMM>LLV(OMM,15) AND OMM<HHV(OMM,10) AND OMM<0 ;
A1:=((MA(C,60)-L)/MA(C,20))*200;
B1:=((MA(C,60)-L)/MA(C,60))*200;
C1:=((MA(C,30)-L)/MA(C,60))*200;
M1:=REF(CLOSE,1);
M2:=SMA(MAX(CLOSE-M1,0),7,1)/SMA(ABS(CLOSE-M1),7,1)*100;
G1:=FILTER(REF(M2,1)<20 AND M2>REF(M2,1),5);
TU:=C/MA(C,40)<0.74;
PER1:=5;
MMA:=EMA(C,PER1);
SMMA:=EMA(MMA,PER1);
IMPETMMA:=MMA - REF(MMA,1);
IMPETSMMA:=SMMA - REF(SMMA,1);
DIVMA:= ABS(MMA - SMMA);
TDJ:=(H-L)/REF(C,1)>0.05;
AVERIMPET:= (IMPETMMA+IMPETSMMA)/2;
TDF:= POW(DIVMA,1)*POW(AVERIMPET,3);
NTDF:=TDF/HHV(ABS(TDF),PER1*3);
YUL:=COUNT(TDJ,5)>1;
QD1:=TU AND TDJ AND YUL;
QD2:=CROSS(NTDF,-0.9);
BD:=FILTER((G1 AND C1>20 OR C>REF(C,1)) AND REF(QD1,1),10);
XG1:=FILTER(REF(QD1,1) AND (QD2 OR C>REF(C,1)) AND "MACD.MACD">-1.5,10);
YD:=COUNT(XG1,13)>=1 AND BD;
XG:BDK AND YD;

{狗头金}
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
老二:=IF(BIAS2<=-10,1,0);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,150);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
爆发:=MACD<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2)
AND REF(MACD ,2)<REF(MACD,3)
AND REF(MACD ,3)<REF(MACD,4);
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
大底:=VAR6<=-10;
VAR11:=CLOSE/MA(CLOSE,20)*100<80;
VAR12:=CLOSE/MA(CLOSE,40)*100<78;
VAR13:=CLOSE/MA(CLOSE,60)*100<72;
VAR14:=HIGH>LOW*1.051;
VAR15:=VAR14 AND COUNT(VAR14,5)>1;
中底:=VAR15 AND (VAR11 OR VAR12 OR VAR13);
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
操盘:=EMA((CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
跟风:=EMA((CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
见到曙光:=CROSS(操盘,跟风) AND 操盘<0 AND 跟风<0;
WW:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
MM:=DMA(CLOSE,WW);
通道4:=(1-7/100)*MM;
VAR84:=EXPMA(CLOSE,9);
LDN:=EXPMA(VAR84*0.86,5);
TYP:=(HIGH+LOW+CLOSE)/3;
TTRR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/TTRR;
MDI:=DMM*100/TTRR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
买底:=C<=通道4 AND C<=LDN AND CCI<-100 AND ADX>=60 AND MDI >= PDI AND CLOSE>OPEN;
VAR82:=LLV(LOW,10);
VAR83:=HHV(HIGH,25);
能量:=EMA((CLOSE-VAR82)/(VAR83-VAR82)*4,4);
关注:=0.5;
红色箭头:=FILTER(CROSS(能量,关注),20);
XXG:=买底 OR 红色箭头;
A:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);
B:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);
MB:=SMA((B-50)*2,3,1)+SMA((A-50)*2,3,1)/2;
GTJ:=MB<-90;
狗头金:GTJ AND COUNT(BB,5) AND COUNT(中底,3) AND NOT(COUNT(XXG,1)) AND NOT(COUNT(见到曙光,3)) AND COUNT(老二,3) AND 大底 AND 爆发,COLORYELLOW;

{高春牛组合}
CAR1:=VOL<MA(VOL,5) AND MA(VOL,5)<MA(VOL,55);
CAR2:=CLOSE/REF(CLOSE,1)>1.028;
CAR3:=MA(CLOSE,10)>CLOSE*1.05;
CAR4:=MA(CLOSE,10)<CLOSE*1.1;
CAR5:=MA(CLOSE,60)>CLOSE*1.28;
金牛:=CAR1 AND CAR2 AND CAR3 AND CAR4 AND CAR5 AND MA(C,20)>REF(MA(C,20),1) AND C>MA(C,5);
DIF1:=(CLOSE-SMA(CLOSE,7,1))/SMA(CLOSE,7,1)*(-100);
DEA1:=REF(DIF1,1)>13 AND REF(DIF1,1)/DIF1>1.3 AND CLOSE/REF(CLOSE,1)>1.03;
KOV:=IF(DEA1 AND REF(CLOSE,1)<=COST(5),28,0);
PIC:=IF(DEA1 AND REF(CLOSE,1)<=COST(5),18,0);
春笋:=IF(DEA1 AND REF(CLOSE,1)<=COST(5),1,0) AND C<MA(C,60) AND MA(C,20)>REF(MA(C,20),1) AND C>MA(C,5);
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
D2:=VAR6<=-10;
VAR11:=CLOSE/MA(CLOSE,30)*100<75;
VAR12:=CLOSE/MA(CLOSE,50)*100<78;
VAR13:=CLOSE/MA(CLOSE,70)*100<72;
VAR14:=HIGH>LOW*1.053;
VAR15:=VAR14 AND COUNT(VAR14,5)>2;
VAR16:=(VAR11 AND VAR12) OR (VAR12 AND VAR13) OR (VAR11 AND VAR13);
D4:=VAR15 AND VAR16;
高精:=D2 AND COUNT(D4,3)>=1 AND MA(C,20)>REF(MA(C,20),1) AND C>MA(C,5);
XG:金牛 OR 春笋 OR 高精;

{赢一波组合}
BIAS0:=(C-MA(C,2))/MA(C,2)*100;
HXL:=V/CAPITAL*100;
D1:=INDEXC;
D2:=MA(D1,13);
DR2:=D2>1.040*D1;
E1:=(C-HHV(C,12))/HHV(C,12)*10;
E2:=(C-REF(C,26))/REF(C,26)*10;
E3:=MA(C,3);
SJ1:=DR2;
SJ2:=E2<-2.30;
SJ3:=BIAS0<-2.7;
SJ5:=SJ1 AND SJ2 AND SJ3;
一:=CROSS(0.5,SJ5);
C1X:=((MA(C,30)-L)/MA(C,60))*200;
M1X:=REF(CLOSE,1);
M2X:=SMA(MAX(CLOSE-M1X,0),7,1)/SMA(ABS(CLOSE-M1X),7,1)*100;
G1X:=FILTER(REF(M2X,1)<20 AND M2X>REF(M2X,1),5);
TUX:=C/MA(C,40)<0.74;
TDJX:=(H-L)/REF(C,1)>0.05;
YULX:=COUNT(TDJX,5)>1;
启动X:=TUX AND TDJX AND YULX;
波:=FILTER((G1X AND C1X>20 OR C>REF(C,1)) AND REF(启动X,1),10);
ETG1:=CLOSE/MA(CLOSE,30)*100<75;
ETG2:=CLOSE/MA(CLOSE,50)*100<78;
ETG3:=HIGH>LOW*1.053;
ETG4:=ETG3 AND COUNT(ETG3,5)>2;
ETG5:=ETG4 AND (ETG1 OR ETG2);
ETG6:=DMA(EMA(CLOSE,5),SUM(VOL,8)/2.8/CAPITAL);
ETG7:=(CLOSE-ETG6)/ETG6*100;
赢:=REF(ETG7,1)<-34 AND ETG7>REF(ETG7,1) AND REF(ETG7,1)<REF(ETG7,2)
AND ETG7-REF(ETG7,1)>1.76 OR ETG5;
XG:赢 AND 一 AND 波;

20个最牛抄底公式及2个组合公式源码

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
20个最牛抄底公式及2个组合公式源码下载
精品股票公式