未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股海绝技 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 通达信公式 > 正文
选股指标成功率测试工具(源码 副图/预警 通达信)
  • 相关简介: 选股指标成功率测试工具(源码 副图/预警 通达信) 送大家一个选股指标成功率的测试工具 要想知道自己选出的个股,在未来几天内能否上涨,涨多少?如果有一个方便的测试工具,也许会给你的抄股带来不少的方便。 只要你的选股指标中选股符号是:XG(如果是别的选股符号,你可以将它改成XG符号)就可以在原选股代码下面加上下面这段代码,就可以在副图上显示你手上选股指标的成功率了。 注:本例是统计在一年所有的选股次数和在三日内达到涨幅2%的成功次数,即成功率。N:=3;{几日内达标,可以随意调,如10,15等}
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境: 通达信
  • 编辑发布: 股海网
  • 软件来源: Internet
  • 加入时间: 2019/5/13 8:43:54
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

选股指标成功率测试工具(源码 副图/预警 通达信

送大家一个选股指标成功率的测试工具
要想知道自己选出的个股,在未来几天内能否上涨,涨多少?如果有一个方便的测试工具,也许会给你的抄股带来不少的方便。
只要你的选股指标中选股符号是:XG(如果是别的选股符号,你可以将它改成“XG”符号)就可以在原选股代码下面加上下面这段代码,就可以在副图上显示你手上选股指标的成功率了。
注:本例是统计在一年所有的选股次数和在三日内达到涨幅2%的成功次数,即成功率。N:=3;{几日内达标,可以随意调,如10,15等}
M:=250;{统计多少日,一年为250日,也可以调成二年,为500}
P:=1.02;{制定涨幅,1.02为涨百分二.也可以调到1.10,即涨幅为百分之十}
一年内选股次数:SUM(XG,M),NODRAW;{提示:作预警要删除NODRAW}
三日内涨二点卖:HHV(H,N)>REF(C,N)*P AND REF(CROSS(XG,0.8),N);{显示成功符号}
一年内成功次数:SUM(三日内涨二点卖,M),NODRAW;
成功率:一年内成功次数/一年内选股次数,NODRAW;
实例:(见图)
注意:下面这段是作为副图指标用,不是作预警的,否则通不过
{任一个选股代码,选股符号是:XG}
EM100:=EMA(EMA(C,2)-EMA(C,150),100);
EM100A:=2*(EMA(C,2)-EMA(C,150)-EM100);
EMP:=POW(EM100A,3)*0.1+POW(EM100A,1);
黑马线:=IF(EM100A>0.1,EMP,0)COLORMAGENTA,LINETHICK3;RS:=CROSS(黑马线,20);
XG:CROSS(JRS,0.8);{显示选股符号}
{统计选股成功率(此例统计在1年内,凡3日内涨幅达到2%的个股),
只要上面选股代码是"XG"就可以加下面一段代码进行统计}
N:=3;{几日内达标,可以随意调,如10,15等}
M:=250;{统计多少日,一年为250日,也可以调成二年,为500}
P:=1.02;{制定涨幅,1.02为涨百分二.也可以调到1.10,即涨幅为百分之十}
一年内选股次数:SUM(XG,M),NODRAW;
三日内涨二点卖:HHV(H,N)>REF(C,N)*P AND REF(CROSS(XG,0.8),N);{显示成功符号}
一年内成功次数:SUM(三日内涨二点卖,M),NODRAW;
成功率:一年内成功次数/一年内选股次数,NODRAW;{要选大于等于1的个股};说明:当你选股的个股较多时,就要从中筛选出成功率高的个股,最好是大于等于1的个股。这样成功的希望就大了。
提示:如果要做成预警选股代码,见下面实例:
注意:下面这段是做预警的,内容基本上和上面一段一样,只是少了NODRAW一词和XG后多了个等号=;

EM100:=EMA(EMA(C,2)-EMA(C,150),100);
EM100A:=2*(EMA(C,2)-EMA(C,150)-EM100);
EMP:=POW(EM100A,3)*0.1+POW(EM100A,1);
黑马线:=IF(EM100A>0.1,EMP,0)COLORMAGENTA,LINETHICK3;
JRS:=CROSS(黑马线,20);
XG:=CROSS(JRS,0.8);{显示选股符号}
N:=3;{几日内达标,可以随意调,如10,15等}
M:=250;{统计多少日,一年为250日,也可以调成二年,为500}
P:=1.02;{制定涨幅,1.02为涨百分二.也可以调到1.10,即涨幅为百分之十}
一年内选股次数:=SUM(XG,M);
三日内涨二点卖:=HHV(H,N)>REF(C,N)*P AND REF(CROSS(XG,0.8),N);{显示成功符号}
一年内成功次数:=SUM(三日内涨二点卖,M);
成功率:=一年内成功次数/一年内选股次数>0.80;{要选大于等于1的个股};
XGT:CROSS(成功率,0.8);

选股指标成功率测试工具(源码 副图/预警 通达信)

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
选股指标成功率测试工具(源码 副图/预警 通达信)下载
精品股票公式