未来函数检测 | 推荐资源 | 热门资源 收藏股海网 | 将股海网放到桌面
股海网,最好股票软件下载中心,股票软件,股票书籍,股票公式,股票知识,炒股教程
股海首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | 股票内参 | 外汇期货 | 股票知识 |
股票软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
股票公式 大智慧 通达信 飞狐 同花顺 东财通 | 股票池 大智慧 通达信 | 股票书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ 股海网 > 指标公式 > 通达信公式 > 正文
通达信主力资金指标公式
  • 相关简介: MACD:MACD.MACD,NODRAW; W1:STICKLINE(MACD0,MACD,0,3,1),COLORRED; W2:STICKLINE(MACD0,MACD,0,3,1),COLORCYAN; VA1:=HHVBARS(MACD,BARSLAST(MACD0)+1); VA2:=CROSS(BACKSET(CROSS(0,MACD),REF(VA1,1)+2),0.5); QG:=CROSS(BACKSET(CROSS(0,MACD) OR (ISLASTBAR AND MAC
  • 文件大小: unknow
  • 浏览次数:
  • 运行环境: 通达信
  • 编辑发布: 股海网
  • 软件来源: www.guhai.com.cn
  • 加入时间: 2014/5/16 6:02:18
  • 解压密码: www.guhai.com.cn(请仔细输入!复制无效!)
  • 下载统计:

股票软件说明:

MACD:"MACD.MACD",NODRAW;
 W1:STICKLINE(MACD>0,MACD,0,3,1),COLORRED;
 W2:STICKLINE(MACD<0,MACD,0,3,1),COLORCYAN;
 VA1:=HHVBARS(MACD,BARSLAST(MACD<0)+1);
 VA2:=CROSS(BACKSET(CROSS(0,MACD),REF(VA1,1)+2),0.5);
 QG:=CROSS(BACKSET(CROSS(0,MACD) OR (ISLASTBAR AND MACD>0),REF(VA1,1)+2),0.5);
前高:DRAWLINE(VA2,MACD,REF(VA2,1),REF(MACD,1),1),COLORMAGENTA;
 VA3:=LLVBARS(MACD,BARSLAST(MACD>0)+1);
 VA4:=CROSS(BACKSET(CROSS(MACD,0),REF(VA3,1)+2),0.5);
 BD:=BARSLAST(FILTERX(CROSS(0,MACD),BARSCOUNT(C)));
前低:DRAWLINE(VA4,MACD,REF(VA4,1),REF(MACD,1),1);
 BDTJ:=IF(MACD<0,FILTERX(MACD=LLV(MACD,BARSLAST(MACD>0)),
 BARSCOUNT(C)),DRAWNULL);
 TSBDTJ:=BARSLAST(BDTJ);
 BDZH:=FILTERX(MACD<CONST(LLV(MACD,BD+1)),BARSCOUNT(C));
 BDTS:=BARSLAST(BDZH);
本低:IF(BD+1>=1,CONST(LLV(MACD,BD+1)),DRAWNULL);
 BDCL:=CROSS(COUNT(CROSS(MACD>本低/2 AND MACD<0,0.5),TSBDTJ)=1,0.5) AND TSBDTJ>=0;
终点:=IF(ISLASTBAR AND MACD>0 AND MACD=HHV(MACD,BARSLAST(MACD<0)),1,
 IF(FILTERX(QG,BARSCOUNT(C)),2,DRAWNULL));
 UU:=(终点=1 OR 终点=2) AND MACD>0;
 ZZ:=FILTERX(UU,BARSCOUNT(C));
本高:DRAWLINE(ZZ,MACD,REF(ZZ,1),REF(MACD,1),1),COLORWHITE;
横线:=CONST(REF(MACD,BARSLAST(ZZ)));
 WW:=MACD>横线;
起始点:=FILTERX(REFX(BARSLAST(WW),1)=1,BARSCOUNT(C));
天数:BARSLAST(起始点),COLORYELLOW,NODRAW;
上横线:DRAWLINE(起始点,横线,ZZ,横线,0),COLORGREEN,DOTLINE;
下横线:DRAWLINE(BDZH,CONST(LLV(MACD,BD+1)),BDTJ=1,MACD,0),COLOR8080FF,DOTLINE;
 DRAWNUMBER(BDTJ,CONST(LLV(MACD,BD+1))*0.9,BDTS);
 DRAWNUMBER(ZZ,上横线*1.1,天数);
TJ:=IF(起始点,BARSNEXT(ZZ),DRAWNULL);
红柱数量:IF(天数>0 AND 天数<=REF(TJ,天数),SUM(MACD>0,天数),DRAWNULL),COLORWHITE,NODRAW;
横线起始价:REF(C,天数),NODRAW;
空间评估:(横线起始价-C)/C*100,NODRAW;
 TT:=BARSLAST(ZZ);
 WQG:=CROSS(COUNT(CROSS(MACD<本高/2 AND MACD>0,0.5),ZZ)=1,0.5) AND ZZ>=0;
 STICKLINE(MACD>前高 AND 本高>前高 AND BARSLAST(CROSS(MACD<本高/2,0.5))>0 AND
 MACD>(前高+本高)/2,MACD,前高,1,0),COLORYELLOW;
前高本高二分位:IF(MACD>0 AND 本高!=前高,DRAWLINE(WQG,(前高+本高)/2,REF(WQG,1),REF((前高+本高)/2,1),1)
 ,DRAWNULL),COLORC0C000,DOTLINE;
 AA:=STRCAT(STRCAT(STRCAT('〖','上升空间'),'〗'),CON2STR(IF(空间评估,空间评估,
DRAWNULL),2));
 DRAWTEXT_FIX(C>0,0,1,0,STRCAT(AA,'﹪')),COLORWHITE;
 DRAWTEXT(WQG,MACD*1.1,'本高成立'),COLORWHITE;
 DRAWTEXT(BDCL,MACD*1.1,'本低成立'),COLORWHITE;
 STICKLINE(MACD>前高,MACD,前高,1,0),COLORYELLOW;
 STICKLINE(WQG,MACD,0,1,0),COLORGREEN;
 STICKLINE(MACD<0 AND MACD<前低 AND 前低<0,MACD,前低,1,0),COLORBLUE;
 B1:=IF(CROSS(MACD<0,0.5),BARSNEXT(BDTJ),DRAWNULL);
 TSB1:=BARSLAST(MACD>0)-1;
 STICKLINE(BARSLAST(BDCL)>=0 AND MACD<前低  AND MACD<0,MACD,前低,1,0),COLORGREEN;
 STICKLINE(BDCL,MACD,0,1,0),COLORWHITE;
 STICKLINE(MACD>前高 AND 本高>前高 AND BARSLAST(WQG)>0,
 MACD,前高,1,0),COLORRED;
 DRAWTEXT(VA2 AND VA2!=UU,(MACD/10)*9,'前');
DRAWTEXT(VA2 AND VA2!=UU,MACD/10,'高');
DRAWTEXT(ZZ,(MACD/10)*9,'本'),COLORWHITE;
 DRAWTEXT(ZZ,MACD/10,'高'),COLORWHITE;
 DRAWTEXT(BDTJ,(MACD/10)*9,'低'),COLORRED;
 DRAWTEXT(BDTJ,MACD/10,'本'),COLORRED;
 IF(BARSLAST(BDCL)>=0,本低/2,DRAWNULL),COLORRED,DOTLINE;  
 VARA1:=(DVOL/C)/2,NODRAW;
 VARA2:=SUM(IF(VARA1>100 AND CLOSE>REF(CLOSE,1),VARA1,0),0);
 VARA3:=SUM(IF(VARA1>100 AND CLOSE<REF(CLOSE,1),VARA1,0),0);
 VARA4:=SUM(IF(VARA1<100 AND CLOSE>REF(CLOSE,1),VARA1,0),0);
 VARA5:=SUM(IF(VARA1<100 AND CLOSE<REF(CLOSE,1),VARA1,0),0);
下面是指标公式:VARA6:=VARA2+VARA3+VARA4+VARA5;
机买:=(VARA2/VARA6)*100,LINETHICK2,COLORRED;
机卖:=(VARA3/VARA6)*100,LINETHICK2,COLORGREEN;
主力差:=机买-机卖,LINETHICK2,NODRAW;
强度:主力差-REF(主力差,1),NODRAW,COLOR6600FF;
 STICKLINE(强度>1.5,-0.05,0,2,0),COLORMAGENTA;
近期:BARSLAST(强度>1.5),NODRAW,COLORGRAY;

通达信主力资金指标公式

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)
通达信主力资金指标公式下载
精品股票公式