当前位置:→ 股海网主题投资 → 正文
  • 通达信股东户数、户均持股自定义数据更新 2018三季报

  • 相关简介:通达信股东户数、户均持股自定义数据更新 2018三季报 需要在通达信自定义数据管理器,分别建立股东户数、户均持股的自定义数据,属性为序列数据。 公式: {股东户数} HS:=SIGNALS_USER(41,1);{此处数值改为自己实际数值} AA:=HSREF(HS,1); BB:=BARSLAST(AA); CC:=BACKSET(ISLASTBAR,BB); HSS:=REF(HS,BB+1); 幅度:=(HS/HSS-1)*100; IF(CC=0,PLOYLINE(AA,HS),DRAW

  • 文章来源:股海网发布时间:2018-11-11浏览次数:下载次数:74收藏:

通达信股东户数、户均持股自定义数据更新 2018三季报

需要在通达信自定义数据管理器,分别建立股东户数、户均持股的自定义数据,属性为“序列数据”。

公式:
{股东户数}
HS:=SIGNALS_USER(41,1);{此处数值改为自己实际数值}
AA:=HS<>REF(HS,1);
BB:=BARSLAST(AA);
CC:=BACKSET(ISLASTBAR,BB);
HSS:=REF(HS,BB+1);
幅度:=(HS/HSS-1)*100;
IF(CC=0,PLOYLINE(AA,HS),DRAWNULL),COLORGREEN;
DRAWBMP(AA,HS,'YELLOWBOLLX');
Z1:=STRCAT(' ',CON2STR(REF(YEAR,BB),0));
Z2:=STRCAT(Z1,'-');
Z3:=STRCAT(Z2,CON2STR(REF(MONTH,BB),0));
Z4:=STRCAT(Z3,'-');
Z5:=STRCAT(Z4,CON2STR(REF(DAY,BB),0));
Z6:=STRCAT('公告日期:',Z5);
Z7:=STRCAT(Z6,'  幅度:');
Z8:=STRCAT(Z7,CON2STR(幅度,2));
Z9:=STRCAT(Z8,'%');
DRAWTEXT_FIX(BB,0.8,0,0,Z9),COLOR00FFFF;

{户均持股}
CG:=SIGNALS_USER(42,1);{此处数值改为自己实际数值}
AA:=CG<>REF(CG,1);
BB:=BARSLAST(AA);
CC:=BACKSET(ISLASTBAR,BB);
CGS:=REF(CG,BB+1);
幅度:=(CG/CGS-1)*100;
IF(CC=0,PLOYLINE(AA,CG),DRAWNULL),COLORRED;
DRAWBMP(AA,CG,'YELLOWBOLLX');
Z1:=STRCAT('幅度:',CON2STR(幅度,2));
Z2:=STRCAT(Z1,'%');
DRAWTEXT_FIX(BB,0.91,0.2,0,Z2),COLOR00FFFF; {下移}
DRAWTEXT_FIX(PERIOD=5,0.0,0.0,0,STRCAT('机构持仓比例: ',EXTERNSTR(0,44))),COLOR0080FF;
 

通达信股东户数、户均持股自定义数据更新 2018三季报

下载链接:( 说明:股海资源如需解压密码的请输入本站域名:www.guhai.com.cn 请仔细输入!)
点击下载资源无反应,请更换浏览器操作(如IE、Chrome浏览器)将股海网设置信任,不要阻止股海网弹出!
本地下载 (免费下载)

通达信股东户数、户均持股自定义数据更新 2018三季报

  • 下载资源所需积分

    0

  • 当前拥有积分

    0

公式解密、改选股联系QQ:78858997(有偿服务)点击查看详情...
股海网指标公式帮助使用说明!新手必读...
股海网新系统使用说明!新手必读...
股海网VIP用户组必读...
精品推荐
说说看法 0条看法

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - SiteMap - TOP
增值电信业务经营ICP许可证:湘B2-20210269   湘ICP备09016573号-10  湘公网安备43108102000040号
股海网客服号QQ:78858997  客服电话:0735-3392968(8:30-17:30)
Copyright © 2020 铭网科技,All Rights Reserved.