当前位置:→ 股海网博易大师公式 → 正文
  • 博易大师指标公式汇总以及源代码集成 文华期货也可使用

  • 相关简介:博易大师指标公式汇总以及源代码集成二》

  • 文章来源:股海网发布时间:2021-10-03浏览次数:下载次数:0收藏:

篇一:《量化经典 博易大师指标公式汇总以及源代码集成二》

最好能配点图片,谢谢

无敌趋势

RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

RSV2:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;

J1:=SMA(RSV1,3,1);J2:=SMA(J1,3,1);

趋势线:3*SMA(RSV2,5,1)-2*SMA(SMA(RSV2,5,1),3,1),LINETHICK2,COLORFF84FF; K:SMA(RSV2,3,1),LINETHICK2,COLORWHITE;

D:SMA(K,3,1),LINETHICK2,COLORF408F4;

DI:IF(趋势线<=10,30,0),LINETHICK2,COLORYELLOW;

KI:IF(CROSS(J2,J1) AND J2>85,70,100),LINETHICK2,COLOR00FF00;

强弱界线:49,POINTDOT,LINETHICK3,COLOR99AACC;

STICKLINE(趋势线>88,100,趋势线,4,1),COLORGREEN;

STICKLINE(趋势线<=10,0,趋势线,4,1),COLORYELLOW;

STICKLINE(COUNT(趋势线<REF(趋势线,1) AND 趋势线<10,2)=2,0,20,4,0),COLORRED; STICKLINE(CROSS(J2,J1) AND J2>85,100,80,4,0),COLORGREEN;

DRAWICON(CROSS(趋势线,49),趋势线,1),COLORRED;

DRAWICON(FILTER(CROSS(D,K) AND D>88,10),D*1.05,2);

DRAWTEXT(CROSS(趋势线,49),47,'转强'),COLORRED;

DRAWTEXT(CROSS(49,趋势线),52,'转弱'),COLORGREEN;


无敌精灵

空方:=(EMA(CLOSE,24)-EMA(CLOSE,4))/2*0.95;

0;多方:=(EMA(CLOSE,4)-EMA(CLOSE,24))/2*0.95;

多头:多方,COLORYELLOW;

空头:空方,,COLORFFFF00;

引路精灵:(多方-空方),COLORRED,LINETHICK2;

STICKLINE(多方>空方 ,0,多方 ,0.8 , 1),COLOREEAAFE;

STICKLINE(空方>多方 ,0,空方 ,0.8 , 1),COLORFFFF00;

STICKLINE(多方>空方 ,0 ,空方 ,0.8 , 1),COLOREEAAFE;

STICKLINE(空方>多方,0 ,多方 ,0.8 , 1),COLORFFFF00;

DRAWICON(CROSS(引路精灵 ,0 ) ,引路精灵+0.3,1 );

买卖航标

VAR1:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;

操盘线:SMA(VAR1,5,1),LINETHICK2,COLORRED;

趋势线:SMA(操盘线,3,1),LINETHICK2,COLORYELLOW;

买入航标:IF(CROSS(操盘线,趋势线) AND 趋势线<25,50,0),LINETHICK2,COLORRED; DRAWTEXT(买入航标>0,50,'买入'),LINETHICK1,COLORRED;

卖出时间:IF(CROSS(趋势线,操盘线)AND操盘线>70,80,100),COLORGREEN;

DRAWTEXT(卖出时间<100,80,'卖出'),LINETHICK1,COLOR00FF00;

天风地火

{天风地火 N:1 100 3 M:1 100 30}

VAR0:=(3*CLOSE+LOW+OPEN+HIGH)/6;

多头线:(20*VAR0+19*REF(VAR0,1)+18*REF(VAR0,2)+17*REF(VAR0,3)+16*REF(VAR0,4)+15*REF(VAR0,5)+14*REF(VAR0,6)+13*REF(VAR0,7)+12*REF(VAR0,8)+11*REF(VAR0,9)+10*REF(VAR0,10)+9*REF(VAR0,11)+8*REF(VAR0,12)+7*REF(VAR0,13)+6*REF(VAR0,14)+5*REF(VAR0,15)+4*REF(VAR0,16)+3*REF(VAR0,17)+2*REF(VAR0,18)+REF(VAR0,20))/210,CIRCLEDOT,COLORRED,LINETHICK2;

空头线: MA(多头线,10), CIRCLEDOT,COLORGREEN,LINETHICK2;

STICKLINE(多头线>空头线,多头线,空头线,10,10),COLORRED;

STICKLINE(多头线<空头线,多头线,空头线,10,10), COLORGREEN;

STICKLINE(C>O,O,C,7,0),COLORRED;

STICKLINE(C>O,O,C,4,0),COLORB0B0FF;

STICKLINE(C>O,O,C,2,0),COLORYELLOW;

STICKLINE(C>O,L,H,0.1,0),COLORYELLOW;

STICKLINE(C< O,O,C,7,0),COLORFF2020;

STICKLINE(C< O,O,C,4,0),COLORFF6600;

STICKLINE(C< O,O,C,2,0),COLORFFCC66;

STICKLINE(C< O,L,H,0.1,0),COLORFFCC66;

STICKLINE(C=O ANDC>=REF(C,1),O,C,7,0),COLORRED;

STICKLINE(C=O ANDC>=REF(C,1),O,C,4,0),COLORB0B0FF;

STICKLINE(C=O ANDC>=REF(C,1),O,C,2,0),COLORYELLOW;

STICKLINE(C=O ANDC>=REF(C,1),L,H,0.1,0),COLORYELLOW;

STICKLINE(C=O AND C<REF(C,1),O,C,7,0),COLORFF2020;

STICKLINE(C=O AND C<REF(C,1),O,C,4,0),COLORFF6600;

STICKLINE(C=O AND C<REF(C,1),O,C,2,0),COLORFFCC66;

STICKLINE(C=O AND C<REF(C,1),L,H,0.1,0),COLORFFCC66;

VAR1:=(CLOSE*1.1)-(CLOSE*0.9)*80

无影手

A1:EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,3),COLORRED; A2:EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA(CLOSE,7))/3,3),COLORRED; A3:EMA((EMA(CLOSE,5)+EMA(CLOSE,7)+EMA(CLOSE,9))/3,3),COLORRED; A4:EMA((EMA(CLOSE,7)+EMA(CLOSE,9)+EMA(CLOSE,11))/3,3),COLORRED; A5:EMA((EMA(CLOSE,9)+EMA(CLOSE,11)+EMA(CLOSE,13))/3,3),COLORRED; A6:EMA((EMA(CLOSE,11)+EMA(CLOSE,13)+EMA(CLOSE,15))/3,3),COLORRED; A7:EMA((EMA(CLOSE,13)+EMA(CLOSE,15)+EMA(CLOSE,17))/3,3),COLORRED; A8:EMA((EMA(CLOSE,15)+EMA(CLOSE,17)+EMA(CLOSE,19))/3,3),COLORRED; A9:EMA((EMA(CLOSE,17)+EMA(CLOSE,19)+EMA(CLOSE,21))/3,3),COLORYELLOW; A10:EMA((EMA(CLOSE,19)+EMA(CLOSE,21)+EMA(CLOSE,23))/3,3),COLORYELLOW; A11:EMA((EMA(CLOSE,21)+EMA(CLOSE,23)+EMA(CLOSE,25))/3,3),COLORYELLOW; A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW; B:=REF(A,1);

DRAWTEXT(A>B,(A+B)/2,'★'), COLORFF00FF;

DRAWTEXT(A<=B,(A+B)/2,'☆'), COLORGREEN;

{STICKLINE(A>B,A,B,8,0),COLORFF00FF;

STICKLINE(A<=B,A,B,8,1),COLORFF0000;}

A15:A-(A1-A*0.997),COLORFF1010;

A16:A-(A2-A),COLORFF2010;

A17:A-(A3-A),COLORFF3010;

A18:A-(A4-A),COLORFF4010;{博易大师公式}.

A19:A-(A5-A),COLORFF5010;

A20:A-(A6-A),COLORFF6010;

A21:A-(A7-A),COLORFF7010;

A22:A-(A8-A),COLORFF8010;

A23:A-(A9-A),COLORFF9010;

A24:A-(A10-A),COLORFFC010;

A25:A-(A11-A*0.997),COLORFFE010;

STICKLINE(OPEN>=CLOSE ,O,C,9,0 ),COLORAAAAAA;

STICKLINE(OPEN>=CLOSE ,O,C,6,0 ),COLORBBBBBB;

STICKLINE(OPEN>=CLOSE ,O,C,2.4,0),COLORCCCCCC;

STICKLINE(OPEN>=CLOSE ,O,C,1.1,0),COLORDDDDDD;

STICKLINE(CLOSE>OPEN,O,C,9,0 ),COLOR6666CC;

STICKLINE(CLOSE>OPEN,O,C,6 ,0 ),COLOR7777DD;

STICKLINE(CLOSE>OPEN,O,C,2.4 ,0 ),COLOR8888EE;

STICKLINE(CLOSE>OPEN,O,C,1.1 ,0 ),COLOR9999FF;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0),COLOR1199FF;

STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0),COLOR1199FF;

STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0),COLORCCCCCC;

STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0),COLORCCCCCC;

VAR31:=(ZIG(3, 19)>REF(ZIG(3,19),1) ANDREF(ZIG(3,19), 1)<REF(ZIG(3,19), 2)); STICKLINE(VAR31=2,L*0.95,L*0.98,8,0),COLOR0000FF;

DRAWTEXT(VAR31=2,L*0.95,'3天'),COLORYELLOW;

STICKLINE(VAR31=4,H*1.05,H*1.02,8,0),COLOR9966FF;

DRAWTEXT(VAR31=4,H*1.06,'5天'),COLORYELLOW;

STICKLINE(VAR31=7,L*0.95,L*0.98,8,0),COLOR00FFFF;

DRAWTEXT(VAR31=7,L*0.95,'8天'),COLORYELLOW;

STICKLINE(VAR31=12,H*1.05,H*1.02,8,0),COLORFF33FF;

DRAWTEXT(VAR31=12,H*1.06,'13天'),COLORYELLOW;

STICKLINE(VAR31=20,L*0.95,L*0.98,8,0),COLOR0066FF;

DRAWTEXT(VAR31=20,L*0.95,'21天'),COLORYELLOW;

STICKLINE(VAR31=33,H*1.05,H*1.02,8,0),COLORFFFF00;

DRAWTEXT(VAR31=33,H*1.06,'34天'),COLORYELLOW;

STICKLINE(VAR31=54,L*0.95,L*0.98,8,0),COLOR006600;

DRAWTEXT(VAR31=54,L*0.95,'55天'),COLORYELLOW;

STICKLINE(VAR31=88,H*1.05,H*1.02,8,0),COLOR00FF00;

DRAWTEXT(VAR31=88,H*1.06,'89天'),COLORYELLOW;

STICKLINE(VAR31=143,L*0.95,L*0.98,8,0),COLORCCFFFF;

DRAWTEXT(VAR31=143,L*0.95,'144天'),COLORYELLOW;

STICKLINE(VAR31=232 ,H*1.05,H*1.02,8,0),COLORFF0033;

DRAWTEXT(VAR31=232,H*1.06,'233天'),COLORYELLOW;

STICKLINE(VAR31=376,L*0.95,L*0.98,8,0),COLORFF9966;

DRAWTEXT(VAR31=376,L*0.95,'377天'),COLORYELLOW;

合并即涨

Var0:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

Var3:=SMA(Var0,3,1);

Var1:=SMA(Var3,4,1)-10;

Var4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;

Var5:=SMA(Var4,3,1);

Var2:=SMA(Var5,4,1)-90;

STICKLINE(REF(Var1,1)<Var1,Var1,REF(Var1,1),10,0),COLOR0000FF;

0, CIRCLEDOT;

STICKLINE(REF(Var1,1)>Var1,Var1,REF(Var1,1),5,0),COLOR00ff00;

STICKLINE(REF(Var2,1)>Var2,Var2,REF(Var2,1),10,0),COLOR0000FF;

STICKLINE(REF(Var2,1)<Var2,Var2,REF(Var2,1),5,0),COLOR00ff00;

0,COLOR0000FF;

顶底奇准

买:=MA(CLOSE,1);

卖:=(LOW+HIGH+CLOSE)/3;

奇:= MA(卖,5);

准:= HHV(奇,10);

急卖奇准:IF(HHV((买<准),5),50,10),COLORFF6699;

STICKLINE(急卖奇准=10,50,10,1,1),COLORFF6699;

短卖奇准:IF(HHV((买<准),10),50,20),COLORGREEN;

STICKLINE(短卖奇准=20,50,20,1,0),COLORGREEN;

TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);

神偷线:=(((DMP ) * 100) / TR);

辅助线:=((DMM * 100) / TR);

XXX:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 + 神偷线)) * 100),3));

奇准:= MA(卖,5);

买卖:=LLV(奇准,10);

底部关注:IF(((XXX > 88) AND (神偷线 < 5.8)),95,50),LINETHICK1,COLORYELLOW; STICKLINE(底部关注=95,50,95,1.5,0),COLORYELLOW,LINETHICK1;

急买奇准:IF(LLV((买<买卖),5),75,50),COLORRED,LINETHICK1;

STICKLINE(急买奇准=75,50,75,1.5,0),COLORRED,LINETHICK1;

短买奇准:IF(LLV((买<买卖),10),85,50),COLORred,LINETHICK1;

STICKLINE(短买奇准=85,50,85,1.5,0),COLORred,LINETHICK1;

ADXR:=((XXX + REF(XXX,3)) / 2);

VAR1:=MA(LOW,1);

VAR2:=MA(HIGH,2);

VAR3:=MA(CLOSE,2);

VAR7:=REF(VAR3,1);

动向趋势线:XXX,LINETHICK2,COLORFFAA66;

一品操盘

{N:1,8,1;}

WR:=ABS(100-100*(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))); IF(WR>0,WR,0),COLORYELLOW;{博易大师公式}.

涨:CROSS(WR,50),POINTDOT,COLOR0000FF;

强:CROSS(WR,80),POINTDOT,COLORYELLOW;

回:CROSS(80,WR) AND WR>50,POINTDOT,COLORWHITE;

险:=COUNT(WR>60,7)>=5 AND WR>90;

跑:=COUNT(WR>60,7)>=5 AND CROSS(80,WR);

慌:WR<=10 AND WR>0,POINTDOT,COLOR00FF00;

绝:WR=0,POINTDOT,COLORFF6600;

买:REF(WR,1)<10 AND C>REF(C,1) AND C>O,POINTDOT,COLORWHITE; 攻:WR>=90 AND WR<100 OR (H=HHV(H,5) H/REF(C,1)>=1.05),POINTDOT,COLORFF00FF;

停:WR=100,POINTDOT,COLORRED;

优选:IF((涨 AND COUNT(WR<=10,6) REF(WR,1)>10)*100,100,50),COLORFF6666,LINETHICK2;

FLSZ:=V*N>REF(V,1) AND C>REF(C,1) AND C>O;

助涨:(涨 OR 强) AND FLSZ,POINTDOT,COLORFF00FF;

DRAWICON(优选=100,50,1); AND AND

篇二:《量化经典 博易大师指标公式汇总以及源代码集成三》

DRAWTEXT(CLOSE>上分形 AND REF(CLOSE,1)<REF(上分形,1),L博易指标公式(量能多空)

DKX:=(EMA(C,18)),POINTDOT;

STICKLINE(((C >=DKX) AND (C >= O)),H,L,0,1),COLORRED;

STICKLINE(((C >=DKX) AND (C >= O)),O,C,2,1),COLORRED;

STICKLINE(((C >=DKX) AND (C <= O)),H,L,0,0),COLORRED;

STICKLINE(((C >=DKX) AND (C <= O)),O,C,2,0),COLORRED;

STICKLINE(((C <DKX) AND (C >= O)),H,L,0,1),COLORGREEN;

STICKLINE(((C < DKX) AND (C >= O)),O,C,2,1),COLORGREEN;

STICKLINE(((C < DKX) AND (C <= O)),H,L,0,0),COLORGREEN;

{博易大师公式}.
STICKLINE(((C < DKX) AND (C <= O)),O,C,2,0),COLORGREEN;

VAR1:=(HHV(HIGH,15)-LLV(LOW,15));

VAR2:=(HHV(HIGH,15)-CLOSE);

VAR3:=(CLOSE-LLV(LOW,15));

VAR4:=(((VAR2/VAR1)*100)-70);

VAR5:=(((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*100); VAR6:=((((2*CLOSE)+HIGH)+LOW)/4);

VAR7:=SMA(((VAR3/VAR1)*100),3,1);

VAR8:=LLV(LOW,34);

VAR9:=(SMA(VAR7,3,1)-SMA(VAR4,9,1));

VAR10:=IF((VAR9>100),(VAR9-100),0);

VAR11:=HHV(HIGH,34);

VAR12:=EMA((((VAR6-VAR8)/(VAR11-VAR8))*100),15);

VAR13:=EMA(((0.667*REF(VAR12,1))+(0.333*VAR12)),2);

MA11:=EMA(VAR13,5);

DRAWTEXT(CROSS(VAR12-VAR13,0),L-1,'多');

DRAWTEXT(CROSS(0,VAR12-VAR13),H+1,'空');

多空参考

(副图)

VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;

VAR2:=SMA(VAR1,10,1);

慢速:=SMA(VAR2,5,1);

RSV:= ((HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100)-70;

RSV1:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

FATK:=SMA(RSV1,3,1);

形态:=SMA(FATK,3,1);

VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VARB:=SMA(VARA,3,1);

VARC:=SMA(VARB,3,1);

加速: EMA(3*VARB-2*VARC,2),COLORYELLOW;

底:6,COLOR00BF00;

大底:-6,COLOR007300;

顶:90,COLORFFA500;

大顶:100,COLORWHITE;

VAR11:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;

VAR22:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;

买入:=VAR11 AND VAR22,LINETHICK2,COLORRED;

VAR3:=REF(CLOSE,1);

VAR4:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100;

卖出:=CROSS(80,VAR4),LINETHICK2,COLORGREEN;

VAR5:=CROSS(加速,100);VAR6:=CROSS(加速,-6);

VAR7:=CROSS(80,加速);VAR8:=CROSS(加速,6);

DRAWTEXT(VAR5,85,'注意顶'),COLORBLUE;

DRAWTEXT(VAR6,0,'关注底'),COLORRED;

DRAWTEXT(VAR7,95,'空'),COLORGREEN;

DRAWTEXT(VAR8,5,'多'),COLORMAGENTA;

趋势顶底

S1:80,COLOR996699,PRECIS0;

B1:20,COLORGREEN,PRECIS0;

A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED; B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2; 长期线:A+100,COLOR9900FF;

短期线:B+100,COLOR888888;

中期线:D+100,COLORYELLOW,LINETHICK2;

见顶:(REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线),PRECIS0;

顶部区域:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5 AND 短期线<中期线 AND 短期线<长期线+4,PRECIS0;

顶部:=FILTER(顶部区域,4);

底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期

线>REF(中期线,1) OR 短期线>REF(短期线,1))) OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1),PRECIS0;

STICKLINE(顶部,98,103,20,1),COLORRED;

STICKLINE(底部区域,-4,0,22,0),COLORGREEN;

STICKLINE(底部区域,40,44,22,0),COLORGREEN;

低位金叉:长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线 AND (REF(短期线,1)<5 OR REF(短期线,2)<5) AND (中期线>=长期线 OR REF(短期线,1)<1),PRECIS0;

PARTLINE(中期线>REF(中期线,1),中期线),COLORMAGENTA,LINETHICK2;

PARTLINE(长期线<=REF(长期线,1),长期线),COLORFFFF00,LINETHICK1;

STICKLINE(低位金叉,0,4,11,0 ),COLORRED;

S0:10,COLORCC6633,LINETHICK2,PRECIS0;

B0:90,COLOR9966BB,LINETHICK2,PRECIS0;

资金量指标

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR3:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;

VAR4:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;

VAR5:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;

VAR6:=(VAR3+VAR4+VAR5)/3;

ZH: EMA(EMA(VAR3,5),5)*3, COLORSTICK;

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR8:=IF(VAR6<=-20,10,0);

STICKLINE(VAR8=10,20,10,4,0),COLORRED;

VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1); DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,5,'狮子提醒'),COLORFF00FF;

STICKLINE(VAR11 AND COUNT(VAR11,30)=1,1,10,8,0),COLORYELLOW;

DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,3,'大资金进入'),COLORFF00FF;

机构做空能量线

VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100; 机构做空能量线: SMA(VAR1,3,1),LINETHICK2,COLORGREEN;

VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

机构做多能量线: SMA(VAR2,5,1)-8,LINETHICK2,COLORRED;

弱势区:20,POINTDOT,COLORGREEN;

强弱分水岭:50,POINTDOT,COLORWHITE;

强势区:80,POINTDOT,COLORF00FF0;

专业快刀手

N1:=21;

VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)- 3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1;

VAR2:=8,COLORGREEN,LINETHICK0;

小试牛刀: IF(CROSS(VAR1,VAR2),50,0),STICK,COLORRED;

DRAWICON(小试牛刀>0,50,4);

发现庄迹: IF(VAR1<=8,15,0),STICK,COLORCYAN,LINETHICK2; VARO5:=LLV(LOW,27);

VARO6:=HHV(HIGH,34);

VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;

建仓区: IF((VARO7<10),100,118) ,COLOR00CCFF,LINETHICK1; CD1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(L,9))-0.7;

CD2:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));

CD3:=SMA(SMA(CD2,3,1),3,1);

CD4:=(CD3-SMA(CD1,9,1))-0.5;

CD5:=IF(CD4>0.00,CD4,0.00);

CD6:=REF(CD5,1);

VAR81:=MA(C,9),COLORRED;

空头1:=IF(CD6-CD5,CD6,CD5),LINETHICK3,COLORGREEN; 减仓空仓:CROSS(CD6,CD5),COLORGREEN;

DRAWICON(减仓空仓>0,113,5);

VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70; VAR2A:=SMA(VAR1A,9,1)+100;

VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; VAR4A:=SMA(VAR3A,3,1);

VAR5A:=SMA(VAR4A,3,1)+100;

VAR6A:=VAR5A-VAR2A;

端庄窝:=IF(VAR6A>N1,VAR6A-N1,0),COLORLIRED;

果断出击:IF(CROSS(端庄窝,0.01),100,0),STICK,COLORGREEN,LINETHICK2; DRAWICON(果断出击>0,100,4),COLORGREEN;

XG:=CROSS(端庄窝,0.01);

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; E:=CROSS(83,RSI);

STICKLINE(REF(端庄窝,1)<端庄窝,端庄窝,REF(端庄窝,1),3,0),COLORRED; STICKLINE(REF(端庄窝,1)>端庄窝,端庄窝,REF(端庄窝,1),3,0),COLOR00FF00; 红持绿空:0,COLORGREEN;

中分线: 20;

VAR1E:=((CLOSE - LLV(LOW,20)) / (HHV(HIGH,20) - LLV(LOW,20))) * 100; VAR2E:=SMA(SMA(VAR1E,3,1),3,1);

VAR3E:=EMA(VAR2E,5);

GZ:=3*VAR2E-2*VAR3E;

趋势J:EMA(GZ,3),colorgreen,linethick3;

partline(趋势J>ref(趋势J,1),趋势J),colorred,linethick3;

VAR37:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR38:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

VAR39:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

副图K线

RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

K:SMA(RSV,3,1);

D:SMA(K,3,1);

J:=3*K-2*D;

100,COLOR00FF00;

0,COLORFF00FF;

STICKLINE(J>REF(J,1),HHV(J,3),LLV(J,3),0,0),COLORRED;

STICKLINE(J>REF(J,1),J,REF(J,1),3,0),COLORRED;

STICKLINE(J>REF(J,1),J,REF(J,1),2,0),COLOR000099;;

STICKLINE(J>REF(J,1),J,REF(J,1),1,0),COLOR2F2FF0;{博易大师公式}.

STICKLINE(J<REF(J,1),HHV(J,3),LLV(J,3),0,0),COLORFFAA00;

STICKLINE(J<REF(J,1),J,REF(J,1),3,0),COLORFF3300;

STICKLINE(J<REF(J,1),J,REF(J,1),1.5,0),COLORFF6600;

STICKLINE(J<REF(J,1),J,REF(J,1),0,0),COLORFFAA00;

一品操盘

STICKLINE(C>=O OR (C=O AND C>REF(C,1)),O,C,4,1),COLORRED;

STICKLINE((C>=O AND C<>H) OR (C=O AND C>REF(C,1)),C,H,0.1,0),COLORRED;

篇三:《博弈大师 精准买卖指标》

博易大师指标公式集锦以及编写方法大集合

(用时把前面空格删掉)

利多方舟

VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21)))); VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21)))); VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34)); DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(CLOSE*0.95),'↑'),COLOR0000FF; DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.035),'卖'),COLORFFFF34; 年:MA(CLOSE,30),COLORGREEN; STICKLINE(C>=年 AND C>=O,C,O,3,0),COLORRED; STICKLINE(C>=年 AND C>=O,H,L,0,0),COLORRED; STICKLINE(C>=年 AND C<O,C,O,3,1),COLORRED; STICKLINE(C>=年 AND C<O,O,H,0,0),COLORRED; STICKLINE(C>=年 AND C<O,C,L,0,0),COLORRED; STICKLINE(C<年 AND C>O,C,O,3,1),COLORFFFF00; STICKLINE(C<年 AND C<=O,C,O,3,1),COLORFFFF00; STICKLINE(C<年 AND C<=O,H,L,0,1),COLORFFFF00; STICKLINE(C<年 AND C>O,C,H,0,1),COLORFFFF00; STICKLINE(C<年 AND C>O,O,L,0,1),COLORFFFF00; 符号↑为"买”

变色MACD

DIFF:(EMA(CLOSE,12) -

EMA(CLOSE,26))*20,COLORFFFFFF,LINETHICK1;

DEA:EMA(DIFF,9),COLOR00FFFF,LINETHICK1; MACD:2*(DIFF-DEA), COLORSTICK; MACD1:2*(DIFF-DEA),COLORRED,LINETHICK0; MACD2:SMA(MACD1,0,3),COLORFFFF00,LINETHICK0; STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED; STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLOR00FFFF; STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLOR40FF00; S1:=MACD<0; S2:= (MACD>=0); S3:=BARSLAST(CROSS(DIFF,DEA)); S4:=REF(S3,S3+1); S5:=DEA>REF(DEA,S4); S6:=DEA; 上成立:=CROSS(DIFF,DEA) AND S5; 下成立:=CROSS(DIFF,DEA) AND S6; L1:=(EMA(CLOSE,3) - EMA(CLOSE,13)); L2:=EMA(L1,9); L3:=BARSLAST(CROSS(L1,L2)); L4:=REF(L3,L3+1); L5:=L2;

变盘:CROSS(L1,L2) AND

L5,LINETHICK0,COLORD6FF9C;

STICKLINE(变盘,5,-5,4,1),COLORD6FF9C;

成立距今:BARSLAST(CROSS(DIFF,DEA)),LINETHICK0;

L6:=BARSCOUNT(CLOSE);

DRAWTEXT(CROSS(L1,L2),DIFF,'买'),COLOR0000FF; DRAWTEXT(CROSS(L2,L1),DIFF,'卖'),COLORFFFF00; REF(DEA,S3),POINTDOT,COLORGREEN; IF(L1>L2,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORB078FF; IF(MACD<0,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORGREEN; LS:=IF(DIFF>DEA AND DIFF>0,1,0); 加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0); XG1:CROSS(MACD1,MACD2) AND MACD1<0,LINETHICK0; XG2:CROSS(DIFF,DEA),LINETHICK0; M1:=MACD>REF(MACD,1) AND DIFF<DEA;

绿柱短了:M1 AND COUNT(M1,10)=1 AND

C>MA(C,55) AND COUNT(MACD<0,5)>=5,LINETHICK0;

DRAWTEXT(绿柱短了,MACD,'绿柱短了'),COLOR00FF80;

渔家乐



家:3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),LINETHICK2

, COLORYELLOW;

渔家乐: IF(CROSS(渔家,MA(渔家,10)) AND 渔家<=10,35,0),LINETHICK3 , COLORMAGENTA;

渔家出海: IF(CROSS(渔家,MA(渔家,10)) AND 渔家{博易大师公式}.

<35,70,0),LINETHICK3 , COLORRED;

渔家网: IF(CROSS(MA(渔家,9),渔家) AND 渔家>70,110,72),LINETHICK1 , COLORCYAN;

DRAWICON(CROSS(渔家,62),68,1);

DRAWICON(CROSS(渔家,72),70,1);

DRAWICON(CROSS(渔家,66),72,1);

DRAWICON(CROSS(渔家,68),66,1);

DRAWICON(CROSS(76,渔家),70,2);

DRAWICON(CROSS(68,渔家),84,2);

DRAWICON(CROSS(66,渔家),80,2);

DRAWICON(CROSS(64,渔家),70,2);

准备下网: IF(渔家<=10,30,0),STICK,COLOR8080FF,LINETHICK4; 此处下网: IF(CROSS(渔家

博易大师指标公式汇总以及源代码集成 文华期货也可使用

  • 下载资源所需积分

    0

  • 当前拥有积分

    0

公式解密、改选股联系QQ:78858997(有偿服务)点击查看详情...
股海网指标公式帮助使用说明!新手必读...
股海网新系统使用说明!新手必读...
股海网VIP用户组必读...
说说看法 0

关于我们 - 联系我们 - 隐私政策 - 免责声明 - 下载帮助 - 广告合作 - SiteMap - TOP
增值电信业务经营ICP许可证:湘B2-20210269 湘ICP备09016573号-10 湘公网安备43108102000040号
股海网客服号QQ:78858997  客服电话:0735-3392968(8:30-17:30)
Copyright © 2021 铭网科技,All Rights Reserved.