当前位置:→ 股海网飞狐公式 → 正文
  • macd结构副图(指标、副图、飞狐、贴图)

  • 相关简介:macd结构副图(指标、副图、飞狐、贴图) 有我的结构图,就不用徐小明的定量结构了。 钝化、结构形成、消失一目了然。另外加上了RIS指标。好不好用,你自己看。 新手上路,好用的多点红心。 源码 DIF:(EMA(C,N)-EMA(C,P1)),Precision2,COLORFF8000,LINEDOT; DEA:EMA(DIF,P2),Precision2,COLOR4080FF,LINEDOT; MACD:(DIF-DEA)*2,Precision2,LINETHICK0; {MACD底部结

  • 文章来源:股海网发布时间:2020-04-01浏览次数:下载次数:0收藏:

macd结构副图(指标、副图、飞狐、贴图)

有我的结构图,就不用徐小明的定量结构了。
钝化、结构形成、消失一目了然。另外加上了RIS指标。好不好用,你自己看。
新手上路,好用的多点红心。

源码

DIF:(EMA(C,N)-EMA(C,P1)),Precision2,COLORFF8000,LINEDOT;
DEA:EMA(DIF,P2),Precision2,COLOR4080FF,LINEDOT;
MACD:(DIF-DEA)*2,Precision2,LINETHICK0;
{MACD底部结构预警}
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
{DRAWTEXT(死叉,DIF*1.05,'↓M死'),COLORF0DC97;}
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),LINETHICK0;
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
STICKLINE(B OR BG,DIF,DEA,3,0),ColorYellow;{柱线带}
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'钝化'),coloryellow;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'形成'),colormagenta;
DRAWTEXT(FILTER(底背离消失,10),MACD*1.1,'消失'),colorgreen;
STICKLINE(BG,0,(DIF+DEA)*0.6,4,0), ColorRED;{柱线}
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
DRAWTEXT(金叉,DIF*1.05,'↑M金'),COLORRED;
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,(DIF+DEA)*0.6,3,0), COLORE79A32;{柱线}
STICKLINE(T OR TG,DIF,DEA,5,0),colorgreen;{柱线带}
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'形成'),colormagenta;
DRAWTEXT(FILTER(顶背离消失,20),MACD*1.2,'消失'),colorgreen;
 FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
 FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
 FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
 FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
 FH5:=FH1 AND FH2 AND MACD<0.10;
二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
 DRAWTEXT(二次翻红,MACD*1.5,'←复红'),COLORFF80FF;
LC:= REF(C,1);
RSI1:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100,LINETHICK0,Precision1;
RSI2:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100,LINETHICK0,Precision1;
RSI3:=SMA(MAX(C-LC,0),24,1)/SMA(ABS(C-LC),24,1)*100,LINETHICK0,Precision1;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2),ColorWhite;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
RSI底背:=B3>0;
DRAWTEXT(B3>0,dif*1.05,'  R底背'),COLORred;{DRAWICON(B3>0,macd*1.2,1);{FILTER(B3>0,3),nodraw;
RSI顶背:=D3>0;DRAWTEXT(D3>0,dif*1.1,'R顶背'),ColorGreen;
STICKLINE(MACD>0 && REF(MACD,1)<MACD, MACD,0,0.11,0),COLORRED;
STICKLINE(MACD>0 && REF(MACD,1)>MACD, MACD,0,0.11,0),COLORYELLOW;
STICKLINE(MACD<0 && REF(MACD,1)<MACD, MACD,0,0.11,0),COLORMAGENTA;
STICKLINE(MACD<0 && REF(MACD,1)>MACD, MACD,0,0.11,0),COLORGREEN;

macd结构副图(指标、副图、飞狐、贴图)

macd结构副图(指标、副图、飞狐、贴图)

  • 下载资源所需积分

    0

  • 当前拥有积分

    0

股海网粉丝必读
公式解密、改选股联系QQ:78858997(有偿服务)点击查看详情...
股海网指标公式帮助使用说明!新手必读...
股海网新系统使用说明!新手必读...
股海网VIP用户组必读...
说说看法 0
推荐资源

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - SiteMap - TOP
Copyright © 2020 铭网科技,All Rights Reserved.湘ICP备09016573号-10
本站所有广告和与股海网均无关系,请股友自行判断真假!股海网客服QQ:78858997
股海网股票软件下载中心
股海网股票书籍下载中心 湘公网安备43108102000040号