当前位置:→ 股海网公式帮助 → 正文
  • 【已解决】麻烦大神根据下面的股票评分公式,修改成选股公式,把5分和6分的股票选出来谢谢!

  • 相关简介:麻烦大神根据下面的股票评分公式,修改成选股公式,把5分和6分的股票选出来谢谢!!!

  • 文章来源:股海网发布时间:2021-11-12浏览次数:下载次数:0收藏:

麻烦大神根据下面的股票评分公式,修改成选股公式,把5分和6分的股票选出来谢谢!!!

A1:=MA(MAX(HHV(H,13),C),2);
A2:=MA(MAX(HHV(H,5),A1),2);
A3:=MA(MAX(HHV(H,3),A2),2);
A4:=MA(MIN(LLV(A3,13),A3),2);
A5:=MA(MIN(LLV(L,13),A4),2);
A6:=(A1+A4+A5)/3;
中线:EMA(SLOPE(MA(C,2),21)*20+MA(C,2),55),COLORGREEN,LINETHICK3;
长线:MA(中线,20);
AC:=IF(C>中线,C*0.98,L),COLORYELLOW;
短A:MA(AC,5);
A8:=IF(C>中线,A1,中线*1.02);
A9:=IF(C>中线,A2,中线*1.02);
A10:=IF(C>中线,A3,中线*1.02);
A11:=(A8+A9+A10)/3;
A12:=MA(A11,10);
短B:MA(短A,5),COLORYELLOW;
DRAWTEXT(CROSS(C,短B),短B,''),COLORRED;
DRAWTEXT(CROSS(C,中线),中线,''),COLORRED;
DRAWTEXT(CROSS(C,长线),长线,''),COLORRED;
DRAWRECTREL(200,10,800,990,90);
DRAWRECTREL(500,100,501,990,60);
DRAWRECTREL(200,100,800,100,60);
DRAWRECTREL(200,200,800,200,60);
DRAWRECTREL(200,300,800,300,60);
DRAWRECTREL(200,400,800,400,60);
DRAWRECTREL(200,500,800,500,60);
DRAWRECTREL(200,600,800,600,60);
DRAWRECTREL(200,700,800,700,60);
DRAWRECTREL(200,800,800,800,60);
DRAWRECTREL(200,900,800,900,60);
DRAWTEXT_FIX(1,0.53,0.05,1,'量 化 辨 股'),COLORYELLOW;
DRAWTEXT_FIX(1,0.35,0.15,1,'买 入 条 件'),COLORYELLOW;
DRAWTEXT_FIX(1,0.65,0.15,1,'卖 出 理 由'),COLORYELLOW;
DRAWTEXT_FIX(1,0.285,0.25,1,'股价上穿短B'),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.35,1,'股价上穿中线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.45,1,'股价上穿长线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.322,0.55,1,'股价收阳且小于3点'),COLORYELLOW;
DRAWTEXT_FIX(1,0.288,0.65,1,'量大于昨同期'),COLORYELLOW;
DRAWTEXT_FIX(1,0.292,0.75,1,'乖离率小于1.2'),COLORYELLOW;
DRAWTEXT_FIX(1,0.26,0.95,1,'买入评分'),COLORYELLOW;
DRAWTEXT_FIX(1,0.58,0.25,1,'股价下穿短A'),COLORGREEN;
DRAWTEXT_FIX(1,0.585,0.35,1,'股价下穿中线'),COLORGREEN;
DRAWTEXT_FIX(1,0.585,0.45,1,'股价下穿长线'),COLORGREEN;
DRAWTEXT_FIX(1,0.61,0.55,1,'股价收阴且小于-2'),COLORGREEN;
DRAWTEXT_FIX(1,0.585,0.65,1,'量小于昨同期'),COLORGREEN;
DRAWTEXT_FIX(1,0.59,0.75,1,'乖离率大于1.2'),COLORGREEN;
DRAWTEXT_FIX(1,0.56,0.95,1,'卖出评分'),COLORGREEN;
T1:=CROSS(C,短B)AND EXIST(CROSS(中线,C),5);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.25,1,T1);
T2:=CROSS(C,中线);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.35,1,T2);
T3:=CROSS(C,长线);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.45,1,T3);
T4:=C>REF(C,1) AND C/REF(C,1)< 1.031;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.55,1,T4);
T5:=V>REF(V,1)*FROMOPEN/240;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.65,1,T5);
T6:=C/中线< 1.21;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.75,1,T6);
买入评分:=T1+T2+T3+T4+T5+T6;
STICKLINE(CURRBARSCOUNT=1 AND C>REF(C,1),C,中线,3,1),COLORRED;
STICKLINE(CURRBARSCOUNT=1 AND C>REF(C,1),长线,中线,2,0),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.95,1,买入评分);
DRAWRECTREL(930,500,970,990,0);
DRAWRECTREL(930,CONST(990-买入评分*100),970,990,95);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.95,0.95,1,买入评分),COLORRED;
DRAWTEXT_FIX(1,0.98,0.75,1,'买入评分'),COLORYELLOW;
T7:=CROSS(短A,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.25,1,T7);
T8:=CROSS(中线,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.35,1,T8);
T9:=CROSS(中线,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.45,1,T9);
T10:=C/REF(C,1)< 0.98;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.55,1,T10);
T11:=V< REF(V,1)*FROMOPEN/240;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.65,1,T11);
T12:=C/中线>1.2;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.75,1,T12);
卖出评分:=T7+T8+T9+T10+T11+T12;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.95,1,卖出评分);
量比前1:=V/(REF(V,1)*FROMOPEN/240);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.35,0.65,1,量比前1);


=========================

股海网答复:买入评分5/6选股公式已经改好,请自行下载公式源码文件,测试图如下:

下载链接:( 说明:股海资源如需解压密码的请输入本站域名:www.guhai.com.cn 请仔细输入!)
点击下载附件资源无反应时,请查阅:下载帮助
评分5_6改选股源码-20211113205518.rar资源大小:505B , 下载积分:-100

【已解决】麻烦大神根据下面的股票评分公式,修改成选股公式,把5分和6分的股票选出来谢谢!

  • 下载资源所需积分

    0

  • 当前拥有积分

    0

公式解密、改选股联系(有偿服务,非诚勿扰)点击查看详情...
股海网指标公式帮助使用说明!新手必读...
股海网新系统使用说明!新手必读...
股海网VIP用户组必读...
说说看法 0

关于我们 - 联系我们 - 隐私政策 - 免责声明 - 下载帮助 - 广告合作 - SiteMap - TOP
增值电信业务经营ICP许可证:湘B2-20210269 湘ICP备09016573号-10 湘公网安备43108102000040号
股海网客服号QQ:78858997  客服电话:0735-3392968(8:30-17:30)
Copyright © 2021 铭网科技,All Rights Reserved.